Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#42 closed enhancement (wontfix)

Mplayer should parse .ram files to extract the real audio stream

Reported by: mplayer@… Owned by: alex@…
Priority: normal Component: core
Version: 1.0pre5 Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The BBC (bbc.co.uk) makes its media available as real audio files.
Unfortunately, these aren't strightforward links, but text files containing the
link. mplayer doesn't currently handle these correctly.

The .ram format is similar to .m3u, and is explained here:
http://service.real.com/help/library/guides/g270/htmfiles/links.htm

Eg:
rjn@mocha rjn]$ mplayer offtheshelf5.ram

-> Fails

rjn@mocha rjn]$ cat offtheshelf5.ram
rtsp://rmv8.bbc.net.uk/worldservice/offtheshelf5_v8.ra
[rjn@mocha rjn]$ mplayer rtsp://rmv8.bbc.net.uk/worldservice/offtheshelf5_v8.ra

-> Works great!

I'm using mplayer-1.0-0.pre5.2plf
Sorry, I had to guess the component.

Thanks a lot

Richard

Change History (5)

comment:1 Changed 15 years ago by reimar

(In reply to comment #0)

The BBC (bbc.co.uk) makes its media available as real audio files.
Unfortunately, these aren't strightforward links, but text files containing the
link. mplayer doesn't currently handle these correctly.

You should have given a link.

rjn@mocha rjn]$ mplayer offtheshelf5.ram

-> Fails

use
mplayer -playlist offtheshelf5.ram
Playlist autodetection was removed because it gave more trouble than it was worth.
Tell me if I may close this bug, it seems to me it isn't really one.

comment:2 Changed 15 years ago by mplayer@…

The BBC's system is slightly crazy - if you look somewhere like this:
http://www.bbc.co.uk/radio/aod/radio3_aod.shtml?r3kitwidow

Then, you have to view the source, and you'll find this link:
http://www.bbc.co.uk/radio/aod/rpms/r3kitwidow.rpm

wget it, and you'll find the file contains (in this case):
[rjn@mocha rjn]$ cat r3kitwidow.rpm

rtsp://rmv8.bbc.net.uk/radio3/r3kitwidow.ra?start=1:02

<!--rtsp://rmv8.bbc.net.uk/radio3/sorry_radio3.rm-->

Then run:
mplayer [cache-options] rtsp://rmv8.bbc.net.uk/radio3/r3kitwidow.ra

Now, I don't mind doing this (although it's a nuisance!), but for any
comparative newbie, they'd never guess, and in fact, there's no reason why we
shouldn't be able to just do:

mplayer http://www.bbc.co.uk/radio/aod/rpms/r3kitwidow.rpm

So please do fix this - it's the only time I've ever know the usually excellent
mplayer to fail when invoked as:
"mplayer some_multimedia_file"

Notes:
1)This bug should really cover .rpm and .ram files
2)I've already taken this up with the BBC, but that hasn't helped.

comment:3 Changed 15 years ago by r_togni@…

I don't get your problem.
mplayer -playlist your_link.rpm plays perfectly.
You have to use -playlist for playlists, like Reimar already told you. That's
mplayer syntax for that kind of files.

Looking at the first link you gave,
http://www.bbc.co.uk/radio/aod/radio3_aod.shtml?r3kitwidow , MPlayer will never
be able to play it. Mplayer is not (yet :)) a web browser.
You need something like mplayer-plugin (http://mplayerplug-in.sourceforge.net/)
but it still doesn't support Real streams (works with mms and qt)

comment:4 Changed 15 years ago by mplayer@…

Sorry! Most of the fault here lies with the BBc for being so &*$% stupid with
the way that they do audio on demand, and not simply giving a link to the real
audio stream itself.

But, it would be nice if mplayer didn't require the -playlist option: because it
is capable of working out that the file is a playlist, then I think it should do
its best to do the right thing. It's the principle of "You should never have to
tell the computer something it already knows". Also, how is the user to know
that a given file is a playlist? I didn't realise to begin with! I just knew
that if all else fails,

mplayer $some_mystery_multimedia_file

will usually play it, and this is that first case in which it didn't!

Also, the error you get when trying to run

mplayer offtheshelf5.ram

is, I think, misleading. It gives an "end of file" error, which led me to assume
that the real-audio stream had EOF'd. It took me quite a bit of thinking before
I discovered the real problem.

comment:5 Changed 15 years ago by dominik@…

  • Resolution set to wontfix
  • Status changed from new to closed

AFAIK the current stance in this matter is that playlist autodetection won't be
reintroduced and it's up to the user (or mplayerplug-in, for example) to handle
this. Closing as WONTFIX.

Note: See TracTickets for help on using tickets.