Opened 15 years ago

Closed 15 years ago

Last modified 14 years ago

#56 closed defect (wontfix)

dpms and screensaver are not re-enabled after exiting sometimes

Reported by: wiebe@… Owned by: alex@…
Priority: normal Component: core
Version: 1.0pre5 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Sometimes, mplayer doesn't enable dpms and the screensaver again after exiting,
even though it says it does. When this has occurred, checking with "xset q"
confirms dpms is disabled. I manually have to run "xset +dpms" to re-anable it.

I can't figure out exactly how to reproduce it. I just open a bunch of movies
and check with "xset q" after each one. After some time, DPMS stays disabled.

I've had this problem for years. On my old LFS system (which I no longer use,
specs below), the problem had the extra of the mplayer process not terminating
when this problem occured.

Current OS:
Linux version: Gentoo Base System version 1.4.16, kernel 2.4.26.
glibc:2.3.3.20040420
GCC: 3.3.3

Old OS:
LFS 3.3, kernel 2.4.18
glibc: 2.2.5
GCC: 2.95.3
Latest version of mplayer used: 1.0pre2(-2.95.3)

Change History (4)

comment:1 Changed 15 years ago by wiebe@…

I've discovered what the cause is. When you exit mplayer with ESC, DPMS is
enabled just fine. When exiting with the close window-button, this message is
given and DPMS stays disabled:

MPlayer interrupted by signal 15 in module: sleep_usleep
Broken pipe

I use Mplayer without GUI, My windowmanager is KDE 3.3.0.

comment:2 Changed 15 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

MPlayer (except for gmplayer and sdl vo) do not support the "close" button. Some
IMNSHO stupid window managers display it anyway and send a kill signal to the
process - causing mplayer to quit immediately. I personally consider this a
windows manager bug, not a MPlayer bug.

comment:3 Changed 14 years ago by reimar

I just changed MPlayer to catch SIGPIPE, can you check if that maybe fixes this
issue, too?

comment:4 Changed 14 years ago by wiebe@…

I downloaded the CVS snapshot of 20050724 and compiled it. It doesn't fix the
issue, but the error message is a bit different. Now I get this:

MPlayer interrupted by signal 15 in module: sleep_rtc

MPlayer interrupted by signal 13 in module: uninit_vo
X connection to :0.0 broken (explicit kill or server shutdown).

Note: See TracTickets for help on using tickets.