Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#66 closed defect (wontfix)

APE (Monkey Audio) dshow

Reported by: x-files@… Owned by: moritz@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hi,
I have an dShow codec for play APE files... In Windows play fine, but when I
use in Mplayer produce this error, Why?

It's the correct mail for post this? If, it's not ok... Please Sorry!!! And
Can you tell me the correct mailpost?
It's a new feature, no¿?

Sample Test -> ftp://ftp.mplayerhq.hu/MPlayer/incoming/monkey/sh3.ape
.ax Codec -> ftp://ftp.mplayerhq.hu/MPlayer/incoming/monkey/RLAPEDec.ax
Guid -> {41FAF0F4-DCEC-4F6A-82D2-56E100F2A8E5}

audiocodec ape

info "Ape"
status untested
format 0x1
driver dshow
dll "rlapedec.ax"
guid 0x41faf0f4, 0xdcec, 0x4f6a, 0x82, 0xd2, 0x56, 0xe1, 0x00, 0xf2, 0xa8,

0xe5

And error:
Opening audio decoder: [dshow] Win32/DirectShow decoders
Warning: DS_Filter() could not find input pin. (DLL=rlapedec.ax, r=0x1)
ERROR: Could not open required DirectShow? codec rlapedec.ax.
ADecoder preinit failed :(
ADecoder init failed :(

Change History (4)

comment:1 Changed 15 years ago by x-files@…

  • Component changed from ad to demuxer
  • Owner changed from alex@… to moritz@…

comment:2 Changed 15 years ago by moritz@…

This directory doesn't exist in incoming, so I can't check your files. Anyway,
have you tried renaming RLAPEDec.ax to rlapedec.ax (upper case to lower case)
because that's what mplayer seems to be looking for.

comment:3 Changed 15 years ago by x-files@…

I reupload the files...
I test renaming RLAPEDec.ax to rlapedec.ax (upper case to lower case) but it
doesn't work!!!

comment:4 Changed 15 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

This is because the decoder is not only a decoder but also a demuxer (it tries
to read the itself, MPlayer only supports filters that take a stream an decode it).
Unfortunaltely the code is not under a license that is compatible with MPlayer
so I guess there will be no support for it (See also
http://www.monkeysaudio.com/smf/index.php?topic=1312.0)

Note: See TracTickets for help on using tickets.