Opened 9 years ago

Closed 9 years ago

#867 closed defect (wontfix)

MPEG: Missing video stream!? Contact the author, it may be a bug :(

Reported by: goga777@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: unspecified Severity: normal
Keywords: Cc: reimar
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

After of the file's anylysis by -identify I have this strange information
ID_VIDEO_WIDTH=0
ID_VIDEO_HEIGHT=0

arvdr:~# /usr/bin/mplayer_svn -vo mpegpes -ao mpegpes -nolirc -identify -
frames 10 -msglevel all=6 /data/mplayer/video/1muz.ts

MPlayer dev-SVN-r23741-4.1.2 (C) 2000-2007 MPlayer Team
CPU: AMD Sempron(tm) Processor 2800+ (Family: 15, Model: 44, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
get_path('codecs.conf') -> '/root/.mplayer/codecs.conf'
Reading /root/.mplayer/codecs.conf: Can't open '/root/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
Configuration: --enable-runtime-cpudetection --enable-largefiles --enable-menu --enable-dvb
CommandLine?: '-vo' 'mpegpes' '-ao' 'mpegpes' '-nolirc' '-identify' '-frames' '10' '-msglevel' 'all=6' '/data/mplayer/video/1muz.ts'
init_freetype
get_path('font/font.desc') -> '/root/.mplayer/font/font.desc'
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
get_path('fonts') -> '/root/.mplayer/fonts'
Using nanosleep() timing
get_path('input.conf') -> '/root/.mplayer/input.conf'
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
get_path('1muz.ts.conf') -> '/root/.mplayer/1muz.ts.conf'

Playing /data/mplayer/video/1muz.ts.
get_path('sub/') -> '/root/.mplayer/sub/'
[file] File size is 5831008 bytes
STREAM: [file] /data/mplayer/video/1muz.ts
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename /data/mplayer/video/1muz.ts ext: .ts
LAVF_check: MPEG2 transport stream format
Checking for Nullsoft Streaming Video
Checking for MOV
Checking for VIVO
header block 1 size: 64
AVS: avs_check_file - attempting to open file /data/mplayer/video/1muz.ts
AVS: File is too big, aborting...
Checking for PVA
Checking for MPEG-TS...
TRIED UP TO POSITION 0, FOUND 47, packet_size= 188, SEEMS A TS? 1
GOOD CC: 31, BAD CC: 0
TS file format detected.
DEMUX OPEN, AUDIO_ID: -1, VIDEO_ID: -1, SUBTITLE_ID: -2,
Checking for MPEG-TS...
TRIED UP TO POSITION 0, FOUND 47, packet_size= 188, SEEMS A TS? 1
GOOD CC: 31, BAD CC: 0
PROBING UP TO 0, PROG: 0
COLLECT_SECTION, start: 64, size: 184, collected: 0
SKIP: 0+1, TID: 0, TLEN: 13, COLLECTED: 184
PARSE_PAT: section_len: 13, section 0/0
PROG: 18 (1-th of 1), PMT: 278
COLLECT_SECTION, start: 64, size: 184, collected: 0
SKIP: 0+1, TID: 2, TLEN: 46, COLLECTED: 184
FILL_PMT(prog=18), PMT_len: 184, IS_START: 64, TS_PID: 278, SIZE=184, M=0, ES_CNT=0, IDX=0, PMT_PTR=0x8b29ab0
...descr id: 0x11, len=1
...descr id: 0x28, len=4
...descr id: 0x2a, len=7
PARSE_PMT(18 INDEX 0), STREAM: 0, FOUND pid=0x21a (538), type=0x10000005, ES_DESCR_LENGTH: 18, bytes left: 10
PARSE_PMT(18 INDEX 1), STREAM: 1, FOUND pid=0x2d5 (725), type=0x50, ES_DESCR_LENGTH: 0, bytes left: 5
PARSE_PMT(18 INDEX 2), STREAM: 2, FOUND pid=0x256 (598), type=0xffffffff, ES_DESCR_LENGTH: 0, bytes left: 0


ID_VIDEO_ID=538
ID_VIDEO_ID=538
ID_VIDEO_ID=538
ID_VIDEO_ID=538

ID_AUDIO_ID=725
COLLECT_SECTION, start: 64, size: 184, collected: 184
SKIP: 0+1, TID: 0, TLEN: 13, COLLECTED: 184
PARSE_PAT: section_len: 13, section 0/0
PROG: 18 (1-th of 1), PMT: 278
COLLECT_SECTION, start: 64, size: 184, collected: 184
SKIP: 0+1, TID: 2, TLEN: 46, COLLECTED: 184
FILL_PMT(prog=18), PMT_len: 184, IS_START: 64, TS_PID: 278, SIZE=184, M=0, ES_CNT=3, IDX=0,
PMT_PTR=0x8b29ab0 ...descr id: 0x11, len=1
...descr id: 0x28, len=4
...descr id: 0x2a, len=7
PARSE_PMT(18 INDEX 0), STREAM: 0, FOUND pid=0x21a (538), type=0x10000005, ES_DESCR_LENGTH: 18, bytes left:
10 PARSE_PMT(18 INDEX 1), STREAM: 1, FOUND pid=0x2d5 (725), type=0x50, ES_DESCR_LENGTH: 0, bytes left: 5
PARSE_PMT(18 INDEX 2), STREAM: 2, FOUND pid=0x256 (598), type=0xffffffff, ES_DESCR_LENGTH: 0, bytes left: 0


ID_VIDEO_ID=538
ID_VIDEO_ID=538
ID_VIDEO_ID=538
..............................
..............................
ID_VIDEO_ID=538
ID_VIDEO_ID=538
ID_VIDEO_ID=538
VIDEO H264(pid=538) AUDIO MPA(pid=725) NO SUBS (yet)! PROGRAM N. 18
==> Found video stream: 0
ID_VIDEO_ID=538

ADDED VIDEO PID 538, type: 10000005 stream n. 0
==> Found audio stream: 0
ID_AUDIO_ID=725

ADDED AUDIO PID 725, type: 50 stream n. 0
Opened TS demuxer, audio: 50(pid 0), video: 10000005(pid 0)...POS=13912, PROBE=0
Searching for sequence parameter set... COLLECT_SECTION, start: 64, size: 184, collected: 0
SKIP: 0+1, TID: 0, TLEN: 13, COLLECTED: 184
PARSE_PAT: section_len: 13, section 0/0
PROG: 18 (1-th of 1), PMT: 278
COLLECT_SECTION, start: 64, size: 184, collected: 0
SKIP: 0+1, TID: 2, TLEN: 46, COLLECTED: 184
FILL_PMT(prog=18), PMT_len: 184, IS_START: 64, TS_PID: 278, SIZE=184, M=0, ES_CNT=3, IDX=0, PMT_PTR=0x8b29ab0
...descr id: 0x11, len=1
...descr id: 0x28, len=4
...descr id: 0x2a, len=7
PARSE_PMT(18 INDEX 0), STREAM: 0, FOUND pid=0x21a (538), type=0x10000005, ES_DESCR_LENGTH: 18, bytes left: 10
PARSE_PMT(18 INDEX 1), STREAM: 1, FOUND pid=0x2d5 (725), type=0x50, ES_DESCR_LENGTH: 0, bytes left: 5
PARSE_PMT(18 INDEX 2), STREAM: 2, FOUND pid=0x256 (598), type=0xffffffff, ES_DESCR_LENGTH: 0, bytes left: 0


OK!
Searching for picture parameter set... H264: 0x168
OK!
Searching for Slice... OK!
FPS seems to be: 25.000000
[V] filefmt:29 fourcc:0x10000005 size:0x0 fps:25.00 ftime:=0.0400
get_path('sub/') -> '/root/.mplayer/sub/'
ID_FILENAME=/data/mplayer/video/1muz.ts
ID_DEMUXER=mpegts
ID_VIDEO_FORMAT=0x10000005
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=0
ID_VIDEO_HEIGHT=0
ID_VIDEO_FPS=25.000
ID_VIDEO_ASPECT=0.0000
ID_AUDIO_FORMAT=80
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=0
ID_AUDIO_NCH=0
ID_LENGTH=0.00
Opening /dev/dvb/adapter0/video0+audio0
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
INFO: libavcodec init OK!
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
ID_VIDEO_CODEC=ffh264
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
dec_audio: Allocating 4608 + 65536 = 70144 bytes for output buffer.
mp3lib: using 3DNow!Ex optimized decore!
MP3lib: init layer2&3 finished, tables done
MPEG 1.0, Layer II, 48000 Hz 128 kbit Stereo, BPF: 384
Channels: 2, copyright: Yes, original: Yes, CRC: Yes, emphasis: 0
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
ID_AUDIO_BITRATE=128000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Building audio filter chain for 48000Hz/2ch/s16le -> 0Hz/0ch/??...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 48000Hz/2ch/s16le
[dummy] Was reinitialized: 48000Hz/2ch/s16le
Opening /dev/dvb/adapter0/audio0
AO: [mpegpes] 48000Hz 2ch s16le (2 bytes per sample)
AO: Description: DVB audio output
AO: Author: A'rpi
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
[dummy] Was reinitialized: 48000Hz/2ch/s16le
[dummy] Was reinitialized: 48000Hz/2ch/s16le
ID_AUDIO_CODEC=mp3
Starting playback...
[h264 @ 0x8968a00]Unknown NAL code: 20
[ffmpeg] aspect_ratio: 1.363636
VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
Trying filter chain: vo
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
SwScale? params: -1 x -1 (-1=no scaling)
Trying filter chain: scale vo
Opening video filter: [lavc]
Trying filter chain: lavc vo
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.36:1 - prescaling to correct movie aspect.
ID_VIDEO_ASPECT=1.3636
VO Config (720x576->786x576,flags=0,'MPlayer',0x32315659)
[mpeg1video @ 0x8968a00]removing common factors from framerate
REQ: flags=0x103 req=0x0
VO: [mpegpes] 720x576 => 786x576 Mpeg PES
VO: Description: Mpeg-PES to DVB card
VO: Author: A'rpi
* [lavc] Exporting mp_image_t, 720x576x12bpp YUV planar, 622080 bytes
* [vo] Exporting mp_image_t, 720x576x0bpp RGB packed, 0 bytes
A:92658.3 V:92659.8 A-V: -1.555 ct: -0.016 5/ 5 ??% ??% ??,?% 0 0

Change History (1)

comment:1 Changed 9 years ago by reimar

  • Cc Reimar.Doeffinger@… added
  • Resolution set to wontfix
  • Status changed from new to closed

Huh? Why did you put that in the summary, it doesn't even appear anywhere in the output you pasted (and it is irrelevant to the problem anyway).
MPEG-TS container does not specify the the resolution, since -identify relies on container info it can't give you the width and height.
So I can see no real bug here, you could at most add a feature request to make -identify also print the resolution the decoder detects.

Note: See TracTickets for help on using tickets.