Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#102 closed defect (fixed)

mp3lib compiled even with --disable-mp3lib

Reported by: basic@… Owned by: reimar
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

--disable-mp3lib disables mp3lib but still compile and link into mplayer.

Attachments (5)

mp3lib.patch (2.8 KB) - added by basic@… 15 years ago.
patch do not compile/link mp3lib when --disable-mp3lib
mp3lib.2.patch (3.2 KB) - added by basic@… 15 years ago.
patch (v2) do not compile/link mp3lib when --disable-mp3lib
disable.patch (3.5 KB) - added by basic@… 15 years ago.
patch v3
disable.2.patch (4.9 KB) - added by reimar 15 years ago.
with additional fix for --disable-liba52 compile
disable.3.patch (5.2 KB) - added by basic@… 15 years ago.
with more fixes for --disable-(liba52|libmpeg2)

Download all attachments as: .zip

Change History (15)

Changed 15 years ago by basic@…

patch do not compile/link mp3lib when --disable-mp3lib

comment:1 Changed 15 years ago by basic@…

Changed 15 years ago by basic@…

patch (v2) do not compile/link mp3lib when --disable-mp3lib

comment:2 Changed 15 years ago by basic@…

  • attachments.isobsolete changed from 0 to 1

missed patch for configure

comment:3 Changed 15 years ago by reimar

+ifeq ($(MP3LIB),yes)
+COMMON_DEPS = mp3lib/libMP3.a
+COMMON_LIBS = mp3lib/libMP3.a
+endif

I guess it should be += here?

And liba52 and libmpeg2 could probably use a modification like this, too. Do you
volunteer to extend your patch? ;-)

Changed 15 years ago by basic@…

patch v3

comment:4 Changed 15 years ago by basic@…

  • attachments.isobsolete changed from 0 to 1

(In reply to comment #3)

+ifeq ($(MP3LIB),yes)
+COMMON_DEPS = mp3lib/libMP3.a
+COMMON_LIBS = mp3lib/libMP3.a
+endif

I guess it should be += here?

oops

And liba52 and libmpeg2 could probably use a modification like this, too. Do

you

volunteer to extend your patch? ;-)

done

Changed 15 years ago by reimar

with additional fix for --disable-liba52 compile

comment:5 Changed 15 years ago by reimar

MPlayer won't compile with --disable-liba52, had to add some ifdefs...
Can you help me test it a bit with various --disable variants? I'll try to get
this into CVS soon.

comment:6 Changed 15 years ago by reimar

  • attachments.isobsolete changed from 0 to 1
  • Owner changed from alex@… to Reimar.Doeffinger@…
  • Status changed from new to assigned

Changed 15 years ago by basic@…

with more fixes for --disable-(liba52|libmpeg2)

comment:7 Changed 15 years ago by basic@…

small change in configure

  • _def_liba52'#undef USE_LIBA52' + _def_liba52='#undef USE_LIBA52'

...

comment:8 Changed 15 years ago by basic@…

  • attachments.isobsolete changed from 0 to 1

comment:9 Changed 15 years ago by basic@…

I've tried with this:

./configure `./configure --help | gawk '/

--(dis|en)able-/{sub("enable","disable",$1);
if(!match($1,/debug|libavcodec|gcc-checking|dga/)) print $1}'` --disable-dga

and it seems to work, I can't try without libavcodec since my ffmpeg doesn't
have the needed header files.

comment:10 Changed 15 years ago by reimar

  • Resolution set to fixed
  • Status changed from assigned to closed

I applied it.

Note: See TracTickets for help on using tickets.