Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1064 closed defect (invalid)

Currently xineramascreen option doesn't do anything

Reported by: thomas.lindroth@… Owned by: reimar
Priority: normal Component: vo
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Some days ago I reported a bug on irc about incorrect scaling in fullscreen mode when using xineramascreen != -1 and using different resolutions on the monitors. The issue was partially fixed in commit r26437. The update_xinerama_info() function now scales fullscreen correctly when using -xineramascreen. However that function also contained the code causing the player window to appear on the desired head and that functionality was not preserved after the fix. According to attila that functionality is suppose to exist somewhere else but it currently does not. This bug report is a reminder that the xineramascreen argument currently doesn't do anything.

I'm more than happy to test any kind of patches. This issue has been bugging me for a while.

Change History (3)

comment:1 Changed 11 years ago by reimar

  • Owner changed from beastd to Reimar.Doeffinger@…

Tell me if I am wrong, but I am quite sure your original "issue" was actually PEBKAC because you missed this part of the man page:

-xineramascreen
...
Will usually only work with "-fstype -fullscreen" or "-fstype none".

comment:2 Changed 11 years ago by thomas.lindroth@…

  • Resolution set to invalid
  • Status changed from new to closed

You were right, I did not see that part of manpage. Sorry about that.

Those fullscreen types seems to make mplayer always use the specified xineramascreen for fullscreen without the ability to move the window between the screens. Is there any way to get the player window to start on the center head and get fullscreen on the screen the player window currently is on when I activate fullscreen?

comment:3 Changed 11 years ago by reimar

I admit you do not get exactly the same behaviour, but -geometry is for that (the main difference is that you can not make MPlayer start exactly centered).
Anything else must be implemented first, and since I have only one monitor is quite low priority to me personally.

Note: See TracTickets for help on using tickets.