Opened 11 years ago

Last modified 8 years ago

#1066 reopened defect

Slow audio in mplayer, it's ok in xine and VLC

Reported by: denilsonsa@… Owned by: reimar
Priority: normal Component: demuxer
Version: 1.0rc2 Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

There is a movie file that plays fine in xine and VLC, but in mplayer the audio is slow. Looks like mplayer detects the audio as 22050Hz, while it should be 48000Hz.

The file is an episode from a TV series. There are 26 episodes (each is a .mkv file of about 260MB). 25 episodes play fine, with correct audio, but 1 has this problem with slow audio.

I suppose you want the file to test it, so here is the torrent:

http://www.mininova.org/det/1302574

The file with problem is:

Shadow Raiders War Planets 104 Bad To The Bone [DVDrip].mkv

Here is some relevant portion of mplayer output for a good file:

Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 160.0 kbit/10.42% (ratio: 20000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)

And now the same portion for that 104 file:

Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 22050 Hz, 2 ch, s16le, 416.0 kbit/58.96% (ratio: 52000->88200)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)

xine detects this "problematic" file as 48000 Hz at 160 kbit/s

Change History (6)

comment:1 Changed 11 years ago by compn

can you upload the first 5 mb of the file?
just start uploading it and stop it after a few minutes
ftp://upload.mplayerhq.hu/MPlayer/incoming

comment:2 Changed 11 years ago by denilsonsa@…

Done. Uploaded it as "bug_1066.mkv".

I've noticed that this incomplete file can't be played in xine, but can be played ok in VLC.

In case you need a bigger portion of the file, just tell me.

comment:3 Changed 11 years ago by compn

  • Component changed from ad to demuxer
  • op_sys changed from Linux to All
  • rep_platform changed from PC (x86 with SSE) to All

looks like a problem with mkv demuxer

comment:4 Changed 8 years ago by compn

  • Resolution set to fixed
  • Status changed from new to closed, patriotact@gmail.com

well -demuxer lavf is default for mkv files. and your sample works ok in svn for me. detected as 48000.

mplayer mkv demuxer isnt maintained in svn anymore so closing this bug.

comment:5 Changed 8 years ago by compn

  • Resolution fixed deleted
  • Status changed from closed to reopened

oops, well it works with mplayer -afm ffmpeg bug_1066.mkv
seems to be a problem with mp3lib decoder.
probably related to the 'missing header' warnings.

comment:6 Changed 8 years ago by compn

  • Owner changed from r_togni@… to reimar
Note: See TracTickets for help on using tickets.