Opened 11 years ago

Closed 10 years ago

#1276 closed defect (fixed)

[PATCH] mov and raw demuxers do not set filepos, so progress stays at 0%

Reported by: rectalogic@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Both the rawvideo and mov demuxers do not update demuxer->filepos and so when transcoding from these formats with mencoder the statusline progress percent stays at 0%.

Attachments (3)

demux_filepos.diff (924 bytes) - added by rectalogic@… 11 years ago.
patch to fix rawvideo and mov demuxers
demux_filepos2.diff (3.3 KB) - added by rectalogic@… 11 years ago.
patch for demux_film.c demux_gif.c demux_mf.c demux_rawaudio.c demux_roq.c demux_vqf.c demux_xmms.c
demux_filepos3.diff (3.3 KB) - added by rectalogic@… 11 years ago.
patch for demux_film.c demux_gif.c demux_mf.c demux_rawaudio.c demux_roq.c demux_vqf.c demux_xmms.c

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by rectalogic@…

patch to fix rawvideo and mov demuxers

comment:1 Changed 11 years ago by rectalogic@…

comment:2 Changed 11 years ago by compn

  • op_sys changed from Mac OS X to All
  • rep_platform changed from PC (x86 with SSE) to All
  • Summary changed from mov and raw demuxers do not set filepos, so progress stays at 0% to [PATCH] mov and raw demuxers do not set filepos, so progress stays at 0%

did you check if any other demuxers are missing this? :)

comment:3 Changed 11 years ago by rectalogic@…

  • op_sys changed from All to Mac OS X
  • rep_platform changed from All to PC (x86 with SSE)

It looks like a few are:

$ grep -L filepos demux_*c
demux_audio.c
demux_avs.c
demux_demuxers.c
demux_film.c
demux_gif.c
demux_mf.c
demux_mpc.c
demux_nemesi.c
demux_rawaudio.c
demux_roq.c
demux_ty_osd.c
demux_vqf.c
demux_xmms.c

I'm attaching a patch for:
demux_film.c
demux_gif.c
demux_mf.c
demux_rawaudio.c
demux_roq.c
demux_vqf.c
demux_xmms.c

Not so sure about the others.

Changed 11 years ago by rectalogic@…

patch for demux_film.c demux_gif.c demux_mf.c demux_rawaudio.c demux_roq.c demux_vqf.c demux_xmms.c

comment:4 Changed 11 years ago by rectalogic@…

Changed 11 years ago by rectalogic@…

patch for demux_film.c demux_gif.c demux_mf.c demux_rawaudio.c demux_roq.c demux_vqf.c demux_xmms.c

comment:5 Changed 11 years ago by rectalogic@…

  • attachments.isobsolete changed from 0 to 1

comment:6 Changed 11 years ago by compn

i wonder how well it works with demux_mf (mf://*.jpg for example)
thanks for checking and updating patch.

comment:7 Changed 10 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Code changed to remove the need for the demuxers to set filepos (unless they want to).
It does not work for mf though, since stream_tell won't work for it.

Note: See TracTickets for help on using tickets.