Opened 11 years ago

Closed 11 years ago

#1289 closed defect (invalid)

Wmv file doesn't play: X11 error: BadShmSeg (invalid shared segment parameter)

Reported by: yuri@… Owned by: reimar
Priority: important Component: core
Version: 1.0rc2 Severity: major
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

http://airport.by/airport_minsk.wmv produces the following console log:

<...skip...>
Connecting to server airport.by[83.222.131.30]: 80...
Stream not seekable!
ASF file format detected.
[asfheader] Audio stream found, -aid 1
[asfheader] Video stream found, -vid 2
VIDEO: [WMV3] 640x480 24bpp 1000.000 fps 512.0 kbps (62.5 kbyte/s)
Clip info:

name:
author: Pavel Guzikov
copyright:
comments:

[VO_XV] Could not grab port 335.
==========================================================================
Opening video decoder: [dmo] DMO video codecs
DMO dll supports VO Optimizations 0 1
DMO dll might use previous sample when requested
GetOutput? r=0x0 size:921600 align:1
StreamCount? r=0x0 1 1
Decoder supports the following formats: YV12 YUY2 UYVY YVYU RGB8 RGB555 RGB565 RGB24 RGB32
Decoder is capable of YUV output (flags 0x1b)
VDec: vo config request - 640 x 480 (preferred colorspace: Packed YUY2)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 640x480 => 640x480 Planar YV12
X11 error: BadAccess? (attempt to access private resource denied)
X11 error: BadAccess? (attempt to access private resource denied)
Selected video codec: [wmv9dmo] vfm: dmo (Windows Media Video 9 DMO)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, s16le, 64.0 kbit/4.54% (ratio: 8005->176400)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================
AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)
Starting playback...
X11 error: BadShmSeg? (invalid shared segment parameter)% ??,?% 0 0
X11 error: BadShmSeg? (invalid shared segment parameter)% 0.6% 0 0
X11 error: BadShmSeg? (invalid shared segment parameter)% 0.6% 0 0
X11 error: BadShmSeg? (invalid shared segment parameter)% 0.6% 0 0
X11 error: BadShmSeg? (invalid shared segment parameter)% 0.6% 0 0
X11 error: BadShmSeg? (invalid shared segment parameter)% 46.9% 1 0
X11 error: BadShmSeg? (invalid shared segment parameter)% 149.5% 2 0
X11 error: BadShmSeg? (invalid shared segment parameter)% 161.3% 3 0
X11 error: BadShmSeg? (invalid shared segment parameter)% 203.9% 4 0

Change History (2)

comment:1 Changed 11 years ago by compn

try as root? is mplayer part of the video group?
looks like a permissions problem.
file plays fine for me.

[VO_XV] Could not grab port 335.
can you get xvideo working on your system? its faster than x11.

comment:2 Changed 11 years ago by yuri@…

  • Resolution set to invalid
  • Status changed from new to closed

Problem went away after I updated the system and rebooted.
Possibly incomplete system update is to blame.

Thank you,
Yuri

Note: See TracTickets for help on using tickets.