Opened 10 years ago

Closed 8 years ago

#1463 closed defect (fixed)

Mplayer crashes while navigating DVD via context menu of gmplayer

Reported by: support@… Owned by: reimar
Priority: important Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I run gmplayer, open DVD, it starts playing. Then I select from menu DVD titles -> Title2, then I select DVD chapters -> any chapter.

Then I get a message Mplayer interrupted by signal 11 in module: demux_open.

Attachments (1)

mplayer_demux_bug.txt (22.3 KB) - added by support@… 10 years ago.
gdb log of debug build

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by support@…

gdb log of debug build

comment:1 Changed 10 years ago by support@…

comment:2 Changed 10 years ago by support@…

Mplayer shows this on start:

MPlayer SVN-r29285-4.3.2 (C) 2000-2009 MPlayer Team
CPU vendor name: GenuineIntel? max cpuid level: 10
CPU: Pentium(R) Dual-Core CPU E5200 @ 2.50GHz (Family: 6, Model: 23, Stepping: 6)
extended cpuid-level: 8
extended cache-info: 134242368
Detected cache-line size is 64 bytes
Testing OS support for SSE... yes.
Tests of OS support for SSE passed.
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNowExt: 0 SSE: 1 SSE2: 1 SSSE3: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2 SSSE3 CMOV

Let me know if you need more information.

comment:3 Changed 8 years ago by compn

  • Owner changed from r_togni@… to reimar

comment:4 Changed 8 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in SVN r32682, but note that gmplayer is unmaintained at this was only fixed because it looks like an issue that might affect non-GUI MPlayer as well.

Note: See TracTickets for help on using tickets.