Opened 10 years ago

Closed 10 years ago

#1563 closed defect (invalid)

flv video plays with distortions and error messages

Reported by: yuri@… Owned by: reimar
Priority: normal Component: core
Version: 1.0rc2 Severity: normal
Keywords: Cc: reimar
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When I try to watch this video
http://study.fivebranches.edu/video_bank/gaoshuzhong200907/1_200907gaoshuzhong.flv

I get many lines like this:
[flv @ 0x8859df0]illegal dc 0 at 0 0
[flv @ 0x8859df0]illegal dc 0 at 0 0
And like this:
[flv @ 0x8859df0]Error at MB:0
[flv @ 0x8859df0]illegal ac vlc code at 0x0

Also video plays with many distortions on the top and the bottom of screen.

MPlayer 1.0rc2-4.2.1

Change History (1)

comment:1 Changed 10 years ago by reimar

  • Cc Reimar.Doeffinger@… added
  • Resolution set to invalid
  • Status changed from new to closed

How was this file created? It most likely is non-compliant to the specification (at least the H.263 one).
To play non-conformant files, -lavdopts er=0 can be used.
If this file was created by some official software, it should be reported to FFmpeg, since the same issue happens there when using the -er option.
I am closing this because either this is a broken file or the issue is actually in the FFmpeg decoder (not because the issue itself is not valid).
As a side note, note that rc2 is about 2 years old and not really supported by us any more, bugs are preferably tested against latest SVN first.
Either way, thanks for the report and if you could file a bug against FFmpeg that would be appreciated (for FFmpeg, easiest way to reproduce this is to use "ffplay 1_200907gaoshuzhong.flv -er 2").

Note: See TracTickets for help on using tickets.