Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#200 closed defect (duplicate)

Make error in ao_alsa: too many arguments to function `snd_pcm_hw_params_get_buffer_size'

Reported by: dimaki@… Owned by: alex@…
Priority: normal Component: ao
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

A make of latest CVS Version fails due to the following error.
Make of 1.0pre6a quits with the same error.
1.0pre5try2-3.2.2 worked fine!


...
cc -c -I../libvo -I../../libvo -I/usr/X11/include -fno-PIC -O4 -march=pentium4
-mcpu=pentium4 -pipe -ffast-math -fomit-frame-pointer -D_REENTRANT
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -I. -I..

-I/usr/X11/include -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2

-I/usr/lib/glib/include -I/usr/X11R6/include -o ao_oss.o ao_oss.c
cc -c -I../libvo -I../../libvo -I/usr/X11/include -fno-PIC -O4 -march=pentium4
-mcpu=pentium4 -pipe -ffast-math -fomit-frame-pointer -D_REENTRANT
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -I. -I..

-I/usr/X11/include -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2

-I/usr/lib/glib/include -I/usr/X11R6/include -o ao_alsa.o ao_alsa.c
ao_alsa.c: In function `init':
ao_alsa.c:561: warning: passing arg 3 of `snd_pcm_hw_params_set_rate_near' makes
integer from pointer without a cast
ao_alsa.c:599: warning: passing arg 3 of
`snd_pcm_hw_params_set_period_size_near' makes integer from pointer without a cast
ao_alsa.c:608: warning: passing arg 3 of `snd_pcm_hw_params_set_periods_near'
makes integer from pointer without a cast
ao_alsa.c:628: too many arguments to function `snd_pcm_hw_params_get_buffer_size'
make[1]: * [ao_alsa.o] Error 1
make[1]: Leaving directory `/tmp/MPlayer-1.0pre6-cvs/libao2'
make:
* [libao2/libao2.a] Error 2


config.h, config.mak and libao2/config.mak is at
ftp://mplayerhq.hu/MPlayer/incoming/20050112_make_ao_alsa_bug.tar.gz

Systeminformation:
==================
SuSE Linux 8.1

Linux sigoslx180 2.4.21-266-default #1 Fri Dec 10 16:16:09 UTC 2004 i686 unknown

-rwxr-xr-x 1 root root 1324935 Nov 23 22:59 /lib/libc.so.6

Reading specs from /usr/lib/gcc-lib/i486-suse-linux/3.2.2/specs
Configured with: ../configure --enable-threads=posix --prefix=/usr
--with-local-prefix=/usr/local --infodir=/usr/share/info --mandir=/usr/share/man
--libdir=/usr/lib --enable-languages=c,c++,f77,objc,java,ada --enable-libgcj
--with-gxx-include-dir=/usr/include/g++ --with-slibdir=/lib --with-system-zlib
--enable-shared --enable-cxa_atexit i486-suse-linux
Thread model: posix
gcc version 3.2.2

GNU ld version 2.12.90.0.15 20020717 (SuSE)
GNU assembler 2.12.90.0.15 20020717 (SuSE)

processor : 0
vendor_id : GenuineIntel?
cpu family : 15
model : 2
model name : Intel(R) Pentium(R) 4 CPU 2.00GHz
stepping : 4
cpu MHz : 2000.066
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips : 3984.58

Acer Incorporated [ALI] i845
X built-in driver

00:1f.5 Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio (rev 01)

Subsystem: Acer Incorporated [ALI]: Unknown device 001b
Control: I/O+ Mem+ BusMaster?+ SpecCycle?- MemWINV- VGASnoop- ParErr?-

Stepping- SERR- FastB2B-

Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr?- DEVSEL=medium >TAbort-

<TAbort- <MAbort- >SERR- <PERR-

Latency: 0
Interrupt: pin B routed to IRQ 11
Region 0: I/O ports at e000 [size=256]
Region 1: I/O ports at e400 [size=64]
Region 2: Memory at ec181000 (32-bit, non-prefetchable) [size=512]
Region 3: Memory at ec182000 (32-bit, non-prefetchable) [size=256]
Capabilities: [50] Power Management version 2

Flags: PMEClk- DSI- D1- D2- AuxCurrent?=375mA

PME(D0+,D1-,D2-,D3hot+,D3cold+)

Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Change History (1)

comment:1 Changed 15 years ago by reimar

  • Resolution set to duplicate
  • Status changed from new to closed

Sounds like bug#58 to me... I do not know why it worked with pre5 though...
Currently the best solution would be to disable ALSA, it is too broken (at the
moment?)...

* This bug has been marked as a duplicate of 58 *

Note: See TracTickets for help on using tickets.