Opened 7 years ago

Closed 7 years ago

#2111 closed defect (fixed)

r35486 breaks playback of mp42

Reported by: tegularius@… Owned by: reimar
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

While playing some mp42 (h264/aac, the like found on various online-video services), audio and video stop for some seconds each. It seems only either of them get playback-time. With -framedrop the matter settles after about 60s (24fps).
I am told "Your system is too SLOW to play this!". It happens only to mp42, other containers (flv, mkv) handling h264/aac seem to be unaffected. It seems to be a stream-file though, but I barely have any knowledge of multimedia. However, the type is common.

I am following current and tracked the problem to r35486. Without that patch everythings works like a charm.

I appended a log from a run with -identify and -v, stripped the status and such at the end.

Attachments (1)

log (9.3 KB) - added by tegularius@… 7 years ago.
mplayer -identify -v -endpos 10 >& log

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by tegularius@…

mplayer -identify -v -endpos 10 >& log

comment:1 Changed 7 years ago by reimar

Please provide one of those problematic files. I tried about 20 different MOV/MP4 files and they all work perfectly fine.

comment:2 Changed 7 years ago by tegularius@…

Putting it here didn't work, I uploaded it to ftp://upload.mplayerhq.hu/incoming/bug-2111-testcase.mp4, I hope that works for you.

comment:3 Changed 7 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Worked around in r35543, but there are issues outside MPlayer:
1) That file is truly horribly muxed, audio and video are not properly interleaved.
2) The FFmpeg libavformat demuxer only interleaves the packets with 1 second granularity, this is rather coarse.

Note: See TracTickets for help on using tickets.