Opened 6 years ago

Closed 6 years ago

#2144 closed defect (wontfix)

Compiling with Live555 fails due ot Live555 API changes

Reported by: jmplayer@… Owned by: reimar
Priority: normal Component: streaming
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description (last modified by reimar)

I've downloaded the current live555 sources from http://www.live555.com/liveMedia/public/, compiled them etc.

Still, the stuff was not detected during configure. Running the detection steps from configure manually gave me the reason why the detection didn't work: The detection code no longer matches the APIs from the includes. So I changed the code to be "valid" again and detection worked fine.
After that, compilation failed due to the API changes and my skills are insufficient to fix that as well.

Change History (3)

comment:1 Changed 6 years ago by jmplayer@…

From the Changelog:

2013.05.30:

  • Support for the old, deprecated 'synchronous' "RTSPClient" interface has now been completely removed. Developers have had three years now to upgrade to using the asynchronous "RTSPClient" interface.

comment:2 Changed 6 years ago by reimar

There is a patch on the mailing list but it still has issues.
Personally I don't use the feature (and do not even know against what streams to test), so this depends on other developers being interested.
For most purposes I think it is possible to play the streams through FFmpeg (which currently might require adding a ffmpeg:// prefix to the URL), but I don't know for sure since as said I don't use the feature.

comment:3 Changed 6 years ago by reimar

  • Analyzed by developer unset
  • Description modified (diff)
  • Reproduced by developer unset
  • Resolution set to wontfix
  • Status changed from new to closed

The fallback to the FFmpeg implementation should be working now.
Unless someone comes up to really polish the patch to update to the new API, we will just drop support for live555.

Note: See TracTickets for help on using tickets.