Opened 6 years ago

Closed 6 months ago

Last modified 6 months ago

#2215 closed enhancement (wontfix)

Wish: video-analysis mode

Reported by: RichardNeill Owned by: beastd
Priority: normal Component: undetermined
Version: 1.1 Severity: normal
Keywords: analysis, kinematics, forensics, single-step, measurements Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

I've just spent a few hours looking very very carefully at high-speed video of an industrial process. Here is a proposal for mplayer to make this an even better tool for analysis/kinematics.

Add an --analysis flag to mplayer. This would do the following:

  1. Turn on OSD, and show the frame number as well as H:m:s. Eg:

0:01:02::21 [or, show fractions of a second: 0:01:02.62 ]

  1. Make the left/right arrow keys advance/reverse only by 1 second rather than 10.
  1. When video is paused, the seek controls (eg left/right arrow) should jump to the next point, but NOT resume playback.
  1. See also wish #2214, for single-stepping backwards.
  1. At the end of the video, the window should not automatically close. It should remain open (we're doing a lot of seeking back and forward, and don't want to quit if we jump to the end).
  1. Don't auto-hide the mouse pointer.
  1. Turn the mouse pointer into cross-hairs. When it is clicked on the video, print (to stdout) the timestamp (to the nearest frame) and the x:y co-ordinates of the click.
  1. When the mouse is right-clicked, also turn that pixel red (and keep it red till we quit).
  1. Optional extra: allow some way to measure distances and speeds.

Thank you for your consideration. :-)

Change History (4)

comment:1 Changed 6 years ago by reimar

As far as I can tell most of what you want can be done by using the -include option to specify a couple of existing options. Not sure what this ticket was mostly for, but if the features you wanted existed, I don't think a special comamnd-line option to combine them would be necessary.

  1. is implemented by the osd-fractions option.

2 and 3 can be edited via input.conf, and -input config=... can be used to load a custom input.conf - this should even be possible to specify in the config file referenced by -include. The "pausing" prefix should be relevant to realize point 3, though the experience might be a bit buggy/sub-optimal currently.

  1. is done by -fixed-vo -idle (though -loop 0 is possibly more useful as -idle keeps the window open and MPlayer running but will still unload the file)
  2. is strangely not an option currently, even though vo_mouse_autohide looks like it was intended to be configurable...

The rest is more complicated. DOCS/tech/slave.txt shows how you can use the run command to write the current time-stamp into a file, however there is no pretty-printing to make it match OSD formatting, nor is there support for getting the mouse position so far.

comment:2 Changed 6 months ago by compn

  • Resolution set to wontfix
  • Status changed from new to closed

can use EDL edit decision list to print the timestamps.

as mplayer is a player and not video analysis tool, i will close this bug.
you might be interested in the Amped FIVE software tool for your specific use.

comment:3 follow-up: Changed 6 months ago by RichardNeill

Thanks for your response. I understand what you mean. I did take a look at the recommended Amped Five, but it's proprietary, and sadly not even on sale to the general public. What I'm suggesting would be extremely useful in the educational arena - for example, as a teacher of physics, it would be great to be able to get tracks of kinematics etc.

As you point out, some of this is existing functionality, with rather more obscure flags, if so, there would be a really good case for adding a "Video Analysis" section to the man page.

comment:4 in reply to: ↑ 3 Changed 6 months ago by beastd

Replying to RichardNeill:
[...]

What I'm suggesting would be extremely useful in the educational arena - for example, as a teacher of physics, it would be great to be able to get tracks of kinematics etc.

As you point out, some of this is existing functionality, with rather more obscure flags, if so, there would be a really good case for adding a "Video Analysis" section to the man page.

Maybe you would like to add some of Reimars advice and how you used MPlayer for your video analysis tasks to this Wiki page: MPlayerUsecaseMagnifier

I created the page years ago, because I wanted to see how close we are to your use case. Never found the time to dig in since. Would still love to see some content there. It may also be a start to identify things that could be made easier and are simple to implement right now.

Note: See TracTickets for help on using tickets.