Opened 3 years ago

Closed 5 weeks ago

#2216 closed defect (needs_more_info)

video stops after few frames when watching TV

Reported by: bexizuo Owned by: beastd
Priority: high Component: undetermined
Version: 1.1 Severity: critical
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

Hi all,

i'm using analog TV card ATI TV Wonder (Bt878) and analog TV Hauppauge HVR 900 (em28XX),

video stops after few frames, first picture is correctly shown , sound is correctly tuned,

second case:
when i try to run mplayer without sound, so video only - i see in status bar the first number always zero:
V: 0.0 957/957 ??% ??% ??,?% 0 0
v4l2: 959 frames successfully processed, 0 frames dropped.
end of second case,

kernel: Debian 3.16.5-1~bpo70+1

command:
mplayer tv:// -tv norm=PAL-BG:freq=687.5:input=0:device=/dev/video0:alsa:adevice=hw.2,0:forceaudio:immediatemode=0 -hardframedrop -vo xv -ao alsa -mc 0

output when video stops:
MPlayer 1.1-4.7 (C) 2000-2012 MPlayer Team
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing tv://.
TV file format detected.
Selected driver: v4l2

name: Video 4 Linux 2 input
author: Martin Olschewski <olschewski@…>
comment: first try, more to come ;-)

Selected device: BT878 video (ATI TV-Wonder)

Tuner cap: STEREO LANG1 LANG2
Tuner rxs: STEREO
Capabilities: video capture video overlay VBI capture device tuner read/write streaming
supported norms: 0 = NTSC; 1 = NTSC-M; 2 = NTSC-M-JP; 3 = NTSC-M-KR; 4 = PAL; 5 = PAL-BG; 6 = PAL-H; 7 = PAL-I; 8 = PAL-DK; 9 = PAL-M; 10 = PAL-N; 11 = PAL-Nc; 12 = PAL-60; 13 = SECAM; 14 = SECAM-B; 15 = SECAM-G; 16 = SECAM-H; 17 = SECAM-DK; 18 = SECAM-L; 19 = SECAM-Lc;
inputs: 0 = Television; 1 = Composite1; 2 = S-Video;
Current input: 0
Current format: YVU420

v4l2: current audio mode is : LANG1
Channel count not available - reverting to default: 2
Channel count not available - reverting to default: 2
==========================================================================
Opening video decoder: [raw] RAW Uncompressed Video
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 640x480 => 640x480 Planar YV12
Selected video codec: [rawyv12] vfm: raw (RAW YV12)
==========================================================================
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 32000 Hz, 2 ch, s16le, 1024.0 kbit/100.00% (ratio: 128000->128000)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
AO: [alsa] 32000Hz 2ch s16le (2 bytes per sample)
Starting playback...
A: 0.0 V: 0.0 A-V: 0.035 ct: 0.000 1/ 1 ??% ??% ??,?% 0 0
[AO_ALSA] Write error: Broken pipe
[AO_ALSA] Trying to reset soundcard.
A: 1.7 V: 0.8 A-V: 0.809 ct: 0.000 54/ 54 0% 0% 174.8% 50 0


Your system is too SLOW to play this!

Possible reasons, problems, workarounds:

  • Most common: broken/buggy _audio_ driver
    • Try -ao sdl or use the OSS emulation of ALSA.
    • Experiment with different values for -autosync, 30 is a good start.
  • Slow video output
    • Try a different -vo driver (-vo help for a list) or try -framedrop!
  • Slow CPU
    • Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts, e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all.
  • Broken file
    • Try various combinations of -nobps -ni -forceidx -mc 0.
  • Slow media (NFS/SMB mounts, DVD, VCD etc)
    • Try -cache 8192.
  • Are you using -cache to play a non-interleaved AVI file?
    • Try -nocache.

Read DOCS/HTML/en/video.html for tuning/speedup tips.
If none of this helps you, read DOCS/HTML/en/bugreports.html.

A: 4.5 V: 2.0 A-V: 2.495 ct: 0.000 124/124 0% 0% 148.7% 120 0
v4l2: 126 frames successfully processed, 0 frames dropped.

Exiting... (Quit)

Change History (2)

comment:1 Changed 3 years ago by reimar

For some reason audio is running far ahead of video, or at least MPlayer believes so.
This is likely the underlying cause.
While I can't say for sure and will have a hard time helping due to lack of hardware, I would suggest trying to remove -hardframedrop and using different -fps options.
A SVN version of MPlayer may also be worth a try.

comment:2 Changed 5 weeks ago by beastd

  • Resolution set to needs_more_info
  • Status changed from new to closed

I hope the problem could be resolved with a bit of parameter tuning.

I don't think we can help more, especially if no developers can reproduce.

Note: See TracTickets for help on using tickets.