Opened 5 years ago

Closed 5 years ago

#2217 closed defect (duplicate)

Can't open subtitles file smaller than 2048b

Reported by: cyrylas Owned by: beastd
Priority: normal Component: core
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

Summary of the bug:

Mplayer can't open external subtitles smaller than 2kb (2048 bytes).

This bug was introduced somewhere between revision 37224 and 37328.

How to reproduce:
Open movie with small subtitles file. Debug output:

[file] File size is 91 bytes      
STREAM: [file] /home/cyryl/Idiocracy.2006.720p.WEB-DL.x264-mSD/Idiocracy.2006.720p.WEB-DL.x264-mSD.txt
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
SUB: Detected subtitle file format: microdvd
SUB: opened iconv descriptor.
SUB: closed iconv descriptor.
SUB: Read 0 subtitles, 0 bad line(s).
Cannot load subtitles '/home/cyryl/Idiocracy.2006.720p.WEB-DL.x264-mSD/Idiocracy.2006.720p.WEB-DL.x264-mSD.txt'.

Change History (3)

comment:1 Changed 5 years ago by beastd

Sorry for the long delay.

Is the problem still reproducible with current MPlayer from SVN?

Was it by chance the same problem as in #2218 ?

comment:2 follow-up: Changed 5 years ago by cyrylas

Can't reproduce it any more on r37343.

So looks fixes to me.

comment:3 in reply to: ↑ 2 Changed 5 years ago by beastd

  • Resolution set to duplicate
  • Status changed from new to closed

Replying to cyrylas:

Can't reproduce it any more on r37343.

So looks fixes to me.

Alright. I'll just close this as a duplicate of #2218 then.

Thank you!

Note: See TracTickets for help on using tickets.