Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#227 closed defect (fixed)

vo_dga.c can't compile against X.org 6.8.0

Reported by: Filip.Jirsak@… Owned by: alex@…
Priority: unimportant Component: vo
Version: 1.0pre6 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When I compile mplayer-1.0_pre6 (the same with pre5) it stops with following errors:

cc -c -I../libvo -I../../libvo -fno-PIC -O2 -march=athlon-xp -frename-registers

-D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I. -I.. -I../osdep

-DMPG12PLAY -o vo_dga.o vo_dga.c

In file included from vo_dga.c:22:
x11_common.h:77: error: parse error before "vo_window"
x11_common.h:77: warning: data definition has no type or storage class
x11_common.h:78: error: parse error before "vo_gc"
x11_common.h:78: warning: data definition has no type or storage class
x11_common.h:79: error: parse error before "vo_hint"
x11_common.h:79: warning: data definition has no type or storage class
x11_common.h:91: error: parse error before '*' token
x11_common.h:92: error: parse error before '*' token
x11_common.h:103: error: parse error before '*' token
vo_dga.c: In function `check_events':
vo_dga.c:321: error: `mDisplay' undeclared (first use in this function)
vo_dga.c:321: error: (Each undeclared identifier is reported only once
vo_dga.c:321: error: for each function it appears in.)
vo_dga.c: In function `flip_page':
vo_dga.c:344: error: `mDisplay' undeclared (first use in this function)
vo_dga.c:344: error: `mScreen' undeclared (first use in this function)
vo_dga.c: In function `uninit':
vo_dga.c:392: error: `mDisplay' undeclared (first use in this function)
vo_dga.c:395: error: `mScreen' undeclared (first use in this function)
vo_dga.c: In function `config':
vo_dga.c:766: error: `mDisplay' undeclared (first use in this function)
vo_dga.c:766: error: `mScreen' undeclared (first use in this function)
vo_dga.c: In function `preinit':
vo_dga.c:897: error: `mDisplay' undeclared (first use in this function)
vo_dga.c:897: error: `mScreen' undeclared (first use in this function)
make[1]: * [vo_dga.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/mplayer-1.0_pre6/work/MPlayer-1.0pr
e6a/libvo'
make:
* [libvo/libvo.a] Error 2

I have X.org v. 6.8.0 on Gentoo Linux on AMD Athlon XP, gcc 3.3.5, glibc
2.3.4.20040808, kernel 2.6.9.

Attachments (3)

config.mak (2.7 KB) - added by Filip.Jirsak@… 14 years ago.
my config.mak
config..vo (115 bytes) - added by Filip.Jirsak@… 14 years ago.
config.mak from libvo directory
vo_dga.o (141.8 KB) - added by Filip.Jirsak@… 14 years ago.
Preparsed vo_dga.o from pre5

Download all attachments as: .zip

Change History (10)

Changed 14 years ago by Filip.Jirsak@…

my config.mak

comment:1 Changed 14 years ago by Filip.Jirsak@…

Changed 14 years ago by Filip.Jirsak@…

config.mak from libvo directory

comment:2 Changed 14 years ago by Filip.Jirsak@…

Changed 14 years ago by Filip.Jirsak@…

Preparsed vo_dga.o from pre5

comment:3 Changed 14 years ago by Filip.Jirsak@…

output from this command (from pre5 version):
cc -E -c -I../libvo -I../../libvo -O2 -march=athlon-xp -D_REENTRANT
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I. -I.. -I../osdep -DMPG12PLAY -o
vo_dga.o vo_dga.c

comment:4 Changed 14 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

You are doing something very weird here, compiling without support for x11, xv
and GL output but with DGA... Anyway, (probably) fixed in CVS

comment:5 Changed 14 years ago by Filip.Jirsak@…

I tried it with as little as possible dependecies - so without X11 and so. But
it was not good idea :-) I'll try CVS version.

comment:6 Changed 14 years ago by Filip.Jirsak@…

  • Priority changed from normal to unimportant
  • Resolution fixed deleted
  • Severity changed from blocker to normal
  • Status changed from closed to reopened

Still happens in CVS (20050206). "./configure" works fine, "./configure
--disable-x11" breaks compilation.
I think ./configure should prepare working environment, so if --disable-x11
implies --disable-dga, it may do it itself, or it may warn user.
This happens to me because I only disabled X11 and leaved autodetection for
other options.

comment:7 Changed 14 years ago by reimar

  • Resolution set to fixed
  • Status changed from reopened to closed

Try again. DGA is now disabled when X11 is disabled (DGA can't work without X
anyway). Though I would have thought the previous patch should have worked as
well...

Note: See TracTickets for help on using tickets.