Opened 9 months ago

Closed 2 months ago

#2316 closed defect (needs_more_info)

mplayer crash on hd stream in module flip page

Reported by: beugrol Owned by: beastd
Priority: lowest Component: undetermined
Version: unspecified Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

Hello,

Summary of the bug:
I ran three windows machine on the same stream udp over the night with the command:
mplayer "stream url"
One of the machine crashed with the following message:

MPlayer interrupted by signal 11 in module: flip_page

  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

mplayer version: Redxii-SVN-r37926-6.2.0 (x86_64)
The OS is the same on every machine: Windows 10 Enterprise 2016 LTSB 64 bits x64
Processor: Intel Celeron CPU J1900 1.99GHZ
RAM: 4,00GO
graphic driver: Intel HD graphics 10.18.10.4425

Stream info (read from a vlc media info):
--video
resolution : 1920x1090
display resolution: 1920x1080
fps: 25
decoded format: Planar 4:2:0 YUV
codec: h264-mpeg-4 AVC (part 10)
--audio
mpeg aac audio mp4a
stereo
48000Hz

context:
lots of logs similar to the following where logged before:
Too many video packets in the buffer: (2516 in 33556382 bytes).
Maybe badly- or non-interleaved stream/file or the codec failed?
Fix the file or try the -ni option (can cause high memory usage).
A:43826.9 V:43827.8 A-V: -0.901 ct: -9.184 1409144/1409144 83% 28% 14.1% 95112
[aac @ 0000000001954e40]invalid band type
A:43835.6 V:43829.0 A-V: 6.604 ct: -9.264 1409186/1409186 83% 28% 14.2% 95116
[h264 @ 0000000001954e40]reference picture missing during reorder
[h264 @ 0000000001954e40]Missing reference picture, default is 2147483647
[h264 @ 0000000001954e40]reference picture missing during reorder
[h264 @ 0000000001954e40]Missing reference picture, default is 1488421
A:43837.4 V:43829.1 A-V: 8.264 ct: -9.280 1409194/1409194 83% 28% 14.2% 95117
[h264 @ 0000000001954e40]reference picture missing during reorder
[h264 @ 0000000001954e40]Missing reference picture, default is 1488436
A:43881.4 V:43833.0 A-V: 48.404 ct: -9.684 1409396/1409396 83% 28% 14.3% 95137

Change History (1)

comment:1 Changed 2 months ago by beastd

  • Resolution set to needs_more_info
  • Status changed from new to closed

Hello!

Sorry for the late reply :(

Are you still experiencing the described problem?

I can't reproduce, so you would need to provide more information.

That's why I am closing this ticket for now. Feel free to re-open.

Note: See TracTickets for help on using tickets.