Opened 7 months ago

Closed 4 weeks ago

#2317 closed defect (fixed)

can not open ISO file containing multibyte path on windows.

Reported by: je-pu-pu Owned by: beastd
Priority: normal Component: undetermined
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: yes

Description

DVDOpen() of MPlayer of Windows version requires
ANSI multibyte path as argument.
But current MPlayer using UTF-8.
( UTF-8 is internal encoding of MPlayer )
Therefore, If .ISO file path is including multibyte,
DVDOpen() ( with libdvdread & libdvdcss ) can't open file.
And MPlayer can't play .ISO file.

Change History (1)

comment:1 Changed 4 weeks ago by beastd

  • Analyzed by developer set
  • Resolution set to fixed
  • Severity changed from blocker to normal
  • Status changed from new to closed
  • Version changed from 1.3 to HEAD

Better late than never :(

This is kind of fixed in SVN since r37937 on 2017-04-29. (Sorry if that patch was from you and I am stating the obvious, but it is better to document the fix in this ticket anyway.)

The fix won't work for files that cannot be represented within your local Windows code page.

I changed the version away from 1.3, as I don't think we will fix this behavior in 1.3 as it has been that way for a long time.

If you have a file that is not fixed by the mentioned commit, feel free to re-open this ticket.

Thank you for reporting the problem. It's appreciated!

Note: See TracTickets for help on using tickets.