Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#249 closed defect (invalid)

useless complile options

Reported by: superandrzej@… Owned by: alex@…
Priority: normal Component: core
Version: 1.0pre6 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I was trying to compile MPlayer using following flags:

CFLAGS="-O2 -march=i486 -mcpu=i686" CXXFLAGS="-O2 -march=i486 -mcpu=i686"

but apparently MPlayer do not accept them. so I tried to bypass them using
followng options:

./configure --target=i686-linux --disable-mmx2 --disable-3dnow --disable-3dnowex
--disable-sse --disable-sse2

but by the end of the ./configure output there was a following message:

Optimizing for: athlon-4 mmx mmx2 3dnow 3dnowex sse mtrr

(BTW. I use AMD Duron.)
So apparently the above options were of no use.

Neigher it was optimized for 686 nor mmx2 3dnow 3dnowex sse were disabled.

the only way to have MPlayer compiled for 686 was use
--enable-runtime-cpudetection option.

So the question is:
What the following options are for if they have no inmpact how MPlayer will be
compiled:
--target=i686-linux --disable-mmx2 --disable-3dnow --disable-3dnowex
--disable-sse --disable-sse2

Change History (1)

comment:1 Changed 14 years ago by dominik@…

  • Resolution set to invalid
  • Status changed from new to closed

I don't know why you say that ./configure doesn't accept user-specified CFLAGS,
because it does. Similarly, all the options you specified do work as you
intended, even if ./configure output is confusing. This is because CPU
capabilities are tested before any of these options take effect. So yes, this is
a bug, but purely cosmetic, not functional.

Try:
CFLAGS="-O2 -march=i486 -mcpu=i686" CXXFLAGS="-O2 -march=i486 -mcpu=i686"
./configure --target=i686-linux --disable-mmx2 --disable-3dnow --disable-3dnowex
--disable-sse --disable-sse2
and look at the generated config.mak

Marking as INVALID.

Note: See TracTickets for help on using tickets.