Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#267 closed defect (fixed)

Illegal Instruction error prevents mplayer start

Reported by: navyjax2@… Owned by: diego@…
Priority: normal Component: vo
Version: 1.0pre6 Severity: normal
Keywords: Cc: dominik@…, zuxy.meng@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Mplayer gives following error when I try to play mpeg or DVD files thus far,
likely it will occur whenever I attempt to use mplayer, I fear... Was hoping
for some help to figure out what I need to do in order to get this to work. I
believe I've included as much information as is needed to determine if it is
hardware or software based. I have even verified I had all the files as is
needed to make it work, and contrary to the error I get, it was compiled and
"ran" on the same computer, with the same CPU installed. It seems to install
OK, though I'm not a programmer to know that for sure. But here is what I get
when I do an "mplayer filename":

Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/local/share/locale

MPlayer 1.0pre6-3.2 (C) 2000-2004 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred (Family: 6, Stepping: 0)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx

CommandLine?: '-v' '/networkdir/Tom/My Videos/WhyMenDontAskDirections?.mpeg'
init_freetype
get_path('font/font.desc') -> '/root/.mplayer/font/font.desc'
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Using Linux hardware RTC timing (1024Hz).
get_path('input.conf') -> '/root/.mplayer/input.conf'
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or
directory
Falling back on default (hardcoded) input config
get_path('WhyMenDontAskDirections?.mpeg.conf') ->
'/root/.mplayer/WhyMenDontAskDirections.mpeg.conf'
Playing /networkdir/Tom/My Videos/WhyMenDontAskDirections?.mpeg.
[file] File size is 2603012 bytes
STREAM: [file] /networkdir/Tom/My Videos/WhyMenDontAskDirections?.mpeg
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for Nullsoft Streaming Video
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename /networkdir/Tom/My
Videos/WhyMenDontAskDirections?.mpeg ext: .mpeg
Checking for MOV
Checking for VIVO
header block 1 size: 0
Checking for PVA
Checking for MPEG-TS...
TRIED UP TO POSITION 67429, FOUND 47, packet_size= 0, SEEMS A TS? 0
Checking for LMLM4 Stream Format
Invalid packet in LMLM4 stream: ch=0 size=553648376
LMLM4 Stream Format not found
system stream synced at 0xB (0)!
==> Found video stream: 0
==> Found audio stream: 0
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)
MPEG-PS file format detected.
Searching for sequence header... OK!

MPlayer interrupted by signal 4 in module: video_read_properties

  • MPlayer crashed by an 'Illegal Instruction'. It usually happens when you run it on a CPU different than the one it was compiled/optimized for. Verify this!
  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

vo: x11 uninit called but X11 not inited..

OS: RHL 8.0
Kernel Version: Linux Linux 2.4.18-14 #1 Wed Sep 4 12:13:11 EDT 2002 i686 athlon
i386 GNU/Linux
Libc Version: libc-2.2.93.so
Gcc Version: gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)
Ld Version: GNU ld version 2.13.90.0.2 20020802
Binutils Version: GNU assembler 2.13.90.0.2 20020802
X color depth: 16 planes

[root@Linux root]# cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 8
model name : mobile AMD Athlon(tm) XP 1500+
stepping : 0
cpu MHz : 1301.468
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 mmx fxsr syscall mmxext 3dnowext 3dnow
bogomips : 2560.17


00:0f.0 VGA compatible controller: VMWare Inc: Unknown device 0405 (prog-if 00
[VGA])

Subsystem: VMWare Inc: Unknown device 0405
Flags: medium devsel
I/O ports at 1400 [size=16]
Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
Memory at f9000000 (32-bit, non-prefetchable) [size=16M]
Expansion ROM at <unassigned> [disabled] [size=32K]

00:11.0 Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet LANCE]
(rev 10)

Subsystem: Advanced Micro Devices [AMD] 79c970 [PCnet LANCE]
Flags: bus master, medium devsel, latency 64, IRQ 10
I/O ports at 10e0 [size=32]

00:12.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 02)

Subsystem: Ensoniq Creative Sound Blaster AudioPCI64V, AudioPCI128
Flags: bus master, ?? devsel, latency 64, IRQ 9
I/O ports at 1080 [size=64]


GDB debugging

[root@Linux mplayer]# gdb ./mplayer
GNU gdb Red Hat Linux (5.2.1-4)
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(gdb) run -v "/networkdir/Tom/My Videos/WhyMenDontAskDirections?.mpeg"
Starting program: /usr/local/lib/mplayer/mplayer -v "/networkdir/Tom/My
Videos/WhyMenDontAskDirections?.mpeg"
[New Thread 8192 (LWP 15299)]
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/local/share/locale

MPlayer 1.0pre6-3.2 (C) 2000-2004 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred (Family: 6, Stepping: 0)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx

CommandLine?: '-v' '/networkdir/Tom/My Videos/WhyMenDontAskDirections?.mpeg'
init_freetype
get_path('font/font.desc') -> '/root/.mplayer/font/font.desc'
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Using Linux hardware RTC timing (1024Hz).
get_path('input.conf') -> '/root/.mplayer/input.conf'
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or
directory
Falling back on default (hardcoded) input config
get_path('WhyMenDontAskDirections?.mpeg.conf') ->
'/root/.mplayer/WhyMenDontAskDirections.mpeg.conf'
Playing /networkdir/Tom/My Videos/WhyMenDontAskDirections?.mpeg.
[file] File size is 2603012 bytes
STREAM: [file] /networkdir/Tom/My Videos/WhyMenDontAskDirections?.mpeg
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for Nullsoft Streaming Video
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename /networkdir/Tom/My
Videos/WhyMenDontAskDirections?.mpeg ext: .mpeg
Checking for MOV
Checking for VIVO
header block 1 size: 0
Checking for PVA
Checking for MPEG-TS...
TRIED UP TO POSITION 67429, FOUND 47, packet_size= 0, SEEMS A TS? 0
Checking for LMLM4 Stream Format
Invalid packet in LMLM4 stream: ch=0 size=553648376
LMLM4 Stream Format not found
system stream synced at 0xB (0)!
==> Found video stream: 0
==> Found audio stream: 0
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)
MPEG-PS file format detected.
Searching for sequence header... OK!

Program received signal SIGILL, Illegal instruction.
[Switching to Thread 8192 (LWP 15299)]
0x08156565 in video_read_properties (sh_video=0x8686ea8) at video.c:275
275 sh_video->fps=picture.fps*0.0001f;
(gdb) bt
#0 0x08156565 in video_read_properties (sh_video=0x8686ea8) at video.c:275
#1 0x08089b2a in main (argc=3, argv=0xbffff944) at mplayer.c:1744
#2 0x4057b4ce in libc_start_main () from /lib/libc.so.6
(gdb) disass $pc-32 $pc+32
Dump of assembler code from 0x8156545 to 0x8156585:
0x8156545 <video_read_properties+1093>: stos %al,%es:(%edi)
0x8156546 <video_read_properties+1094>: aas
0x8156547 <video_read_properties+1095>: xor %eax,%eax
0x8156549 <video_read_properties+1097>: mov 0x8(%ebp),%esi
0x815654c <video_read_properties+1100>: fldz
0x815654e <video_read_properties+1102>: cmpl $0x0,0x85bac00
0x8156555 <video_read_properties+1109>: sete %al
0x8156558 <video_read_properties+1112>: add $0x10000001,%eax
0x815655d <video_read_properties+1117>: mov %eax,0x8(%esi)
0x8156560 <video_read_properties+1120>: mov 0x85bac14,%eax
0x8156565 <video_read_properties+1125>: cvtsi2ss %eax,%xmm0
0x8156569 <video_read_properties+1129>: movss %xmm0,0xfffffff0(%ebp)
0x815656e <video_read_properties+1134>: flds 0xfffffff0(%ebp)
0x8156571 <video_read_properties+1137>: fmuls 0x84a2d60
0x8156577 <video_read_properties+1143>: fucomi %st(1),%st
0x8156579 <video_read_properties+1145>: fstps 0x24(%esi)
0x815657c <video_read_properties+1148>:

jne 0x815666c <video_read_properties+1388>

---Type <return> to continue, or q <return> to quit---
0x8156582 <video_read_properties+1154>:

jp 0x815664d <video_read_properties+1357>

End of assembler dump.
(gdb) info all-registers
eax 0x492b4 299700
ecx 0x4086400c 1082540044
edx 0x0 0
ebx 0x8686d30 141061424
esp 0xbfffd590 0xbfffd590
ebp 0xbfffd5d8 0xbfffd5d8
esi 0x8686ea8 141061800
edi 0x8686d98 141061528
eip 0x8156565 0x8156565
eflags 0x202 514
cs 0x23 35
ss 0x2b 43
ds 0x2b 43
es 0x2b 43
fs 0x0 0
gs 0x0 0
st0 0 (raw 0x00000000000000000000)
st1 0 (raw 0x00000000000000000000)
st2 0 (raw 0x00000000000000000000)
---Type <return> to continue, or q <return> to quit---
st3 0 (raw 0x00000000000000000000)
st4 0 (raw 0x00000000000000000000)
st5 0 (raw 0x00000000000000000000)
st6 0 (raw 0x00000000000000000000)
st7 0.558277785778045654296875 (raw 0x3ffe8eeb4b0000000000)
fctrl 0x37f 895
fstat 0x3820 14368
ftag 0x7fff 32767
fiseg 0x0 0
fioff 0x0 0
foseg 0x0 0
fooff 0x0 0
fop 0x0 0
xmm0 {f = {0x0, 0x0, 0x0, 0x0}} {f = {-nan(0x7fffff),

-nan(0x7fffff), -nan(0x7fffff), -nan(0x7fffff)}}

xmm1 {f = {0x0, 0x0, 0x0, 0x0}} {f = {-nan(0x7fffff),

-nan(0x7fffff), -nan(0x7fffff), -nan(0x7fffff)}}

xmm2 {f = {0x0, 0x0, 0x0, 0x0}} {f = {-nan(0x7fffff),

-nan(0x7fffff), -nan(0x7fffff), -nan(0x7fffff)}}

---Type <return> to continue, or q <return> to quit---
xmm3 {f = {0x0, 0x0, 0x0, 0x0}} {f = {-nan(0x7fffff),

-nan(0x7fffff), -nan(0x7fffff), -nan(0x7fffff)}}

xmm4 {f = {0x0, 0x0, 0x0, 0x0}} {f = {-nan(0x7fffff),

-nan(0x7fffff), -nan(0x7fffff), -nan(0x7fffff)}}

xmm5 {f = {0x0, 0x0, 0x0, 0x0}} {f = {-nan(0x7fffff),

-nan(0x7fffff), -nan(0x7fffff), -nan(0x7fffff)}}

xmm6 {f = {0x0, 0x0, 0x0, 0x0}} {f = {-nan(0x7fffff),

-nan(0x7fffff), -nan(0x7fffff), -nan(0x7fffff)}}

xmm7 {f = {0x0, 0x0, 0x0, 0x0}} {f = {-nan(0x7fffff),

-nan(0x7fffff), -nan(0x7fffff), -nan(0x7fffff)}}

mxcsr 0x1f80 8064
orig_eax 0xffffffff -1

Please send whatever you find may be some things I can try to navyjax2@….

Thanks.

Tom

Change History (8)

comment:1 Changed 14 years ago by dominik@…

Have you tried running MPlayer on real hardware, not VMWare? VMWare is not a
supported environment.

comment:2 Changed 14 years ago by navyjax2@…

I was e-mailed by someone in response to my previous post. I've since lost the
e-mail and therefore the address to respond to, so I figured I'd post my
response back here.

The question was whether I had installed mplayer on anything other than VMWare.

The answer is no, I haven't, but by all indications I don't see why it wouldn't

work even within that. I've installed Acrobat Reader, XMMS, AIM, and Java thus
far with no issues, though with RPMs, not from source. With me relatively new
to Linux, I must say a computer dedicated solely to Linux, if I could spare one,
would not get the use that my Windows computers receive. Unless they come in
RPMs I've not wanted to take the time to use the ./configure, make, make install
method using the source code .c files until I found mplayer. Linux applications
and utilities I've wanted to install that have come with only source I've
generally avoided for their time-consuming and buggy nature from what I've
noticed on the web forums. I don't like taking a lot of time to build something
and it not bear fruit. Unfortunately with mplayer, I couldn't find any RPMs for
it, and all the sites said "Build your own! It'll be best that way!" Hmmm...
Well, now I'd just like to know if there are any mplayer RPMs out there, just so
I can know that it isn't my OS or whatever that's preventing it from running.
And that way I'd have a cool utility to play all the .mpg, .avi, and DVD files
out there, my reason for wanting it in the first place. So if someone has one,
or knows where to get it, or even another video player, please send it or the
link to navyjax2@…, unless I just don't have the right version or
something of the compilers and all from my post I put up, and then I could
download and install them instead and re-run the make commands. Thanks either way.

comment:3 Changed 14 years ago by dominik@…

You couldn't find RPMs? How about following a link right on MPlayer's download
page? Go to http://www.mplayerhq.hu/homepage/design7/dload.html and click on
RedHat/Fedora? RPMs link there. Granted, RH8 is not supported by me, but I try to
make it so that it builds cleanly on all RedHats?, so all you need to do is grab
the source RPM and rebuild it. Just go to
http://luna.cs.ccsu.edu/dominik/mplayer/rebuilding.html (US mirror) and read. It
should be easy enough to follow.

As to VMware, I still think it's the culprit here. MPlayer uses hardware
directly in many ways to achieve fastest playback possible and to keep the a-v
sync, so it's only fair to assume that any hardware virtualization will
interfere with that.

comment:4 Changed 14 years ago by dominik@…

  • Cc dominik@… added

comment:5 Changed 14 years ago by compn

  • op_sys changed from Linux to Other

changed OS to other because of vmware.

also sent email:
hi, i read your bugzilla, was wondering if you have tried using the cpuruntime
detection switch during configure or just disable all the mmx, mmx2, 3dnow stuff.

or use the win32 mplayer http://mplayerhq.hu/MPlayer/releases/win32-beta/
or use CoLinux?, ability to run linux in win2k/xp, no rebooting/emulation needed
altho sound works with colinux, i dont know about video. (i've tested colinux +
knoppix + mplayer compile/install/playback with -vo caca).

anyways, good luck.

comment:6 Changed 14 years ago by zuxy.meng@…

This is the problem:

cvtsi2ss %eax,%xmm0

Your gcc shouldn't generate this since your CPU dosen't support SSE. Would you
please paste your config.mak here?

comment:7 Changed 14 years ago by diego@…

  • Owner changed from alex@… to diego@…

comment:8 Changed 14 years ago by diego@…

  • Cc zuxy.meng@… added
  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed now by a patch from Zuxy Meng. Please report back if your
problem persists with current CVS.

Note: See TracTickets for help on using tickets.