Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#286 closed defect (fixed)

Quicktime files generated by kodak DX6340 have black margins

Reported by: tsdgeos@… Owned by: alex@…
Priority: normal Component: vo
Version: 1.0pre6 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The file http://usuarios.lycos.es/tsdgeos/100_0012.MOV plays correctly
although it has black margins at lower and right part that are not part of the
file (at least quicktime in windows does not show them)

If need more info do not hesitate to ask and thanks for that cool app :-)



Distribution: Mandriva LE 2005
Linux localhost 2.6.11-6mdk #1 Tue Mar 22 16:04:32 CET 2005 i686 AMD
Athlon(tm) XP 1600+ unknown GNU/Linux
libc: 2.3.4
gcc: 3.4.3
ld: 2.15.92.0.2 20040927
binutils: 2.15.92.0.2 20040927

Log:

MPlayer 1.0pre6-3.4.3 (C) 2000-2004 MPlayer Team
CPU: Advanced Micro Devices Athlon 4 /Athlon MP/XP Palomino (Family: 6,
Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with
--disable-runtime-cpudetection.


77 audio & 188 video codecs
CommandLine?: '-v' 'fotos/todas/100_0012.MOV'
init_freetype
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system
startup scripts.
Using nanosleep() timing
get_path('input.conf') -> '/home/tsdgeos/.mplayer/input.conf'
Can't open input config file /home/tsdgeos/.mplayer/input.conf: No such file
or directory
Parsing input config file /etc/mplayer/input.conf
Input config file /etc/mplayer/input.conf parsed: 59 binds
Can't init input joystick
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
get_path('100_0012.MOV.conf') -> '/home/tsdgeos/.mplayer/100_0012.MOV.conf'
Playing fotos/todas/100_0012.MOV.
[file] File size is 358432 bytes
STREAM: [file] fotos/todas/100_0012.MOV
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
CACHE_PRE_INIT: 0 [0] 0 pre:0 eof:358432

Cache fill: 4,27% (358432 bytes) Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for Nullsoft Streaming Video
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename fotos/todas/100_0012.MOV ext: .MOV
Trying demuxer 7 based on filename extension
Checking for MOV
MOV: Movie DATA found!
MOV: Movie header found!
QuickTime?/MOV file format detected.
MOV: Movie header (100 bytes): tscale=168000 dur=230580


MOV: Track #0:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=1 dur=230580 lay=0 vol=0
MOV: Media stream!
MOV: Media header!
MOV: Handler header: mhlr/vide ()
MOV: Media info!
MOV: Video header!
MOV: Handler header: dhlr/alis ()
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: h263 (70 bytes)
MOV: Sample duration table! (1 blocks)
MOV: Sample->Chunk mapping table! (1 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=21 ss=0) (ver:0,flags:0)
MOV: Chunk offset table! (7 chunks)
MOV track #0: 7 chunks, 21 samples
pts=230580 scale=168000 time=1,373
==> Found video stream: 0
Image size: 320 x 240 (24 bpp)
Display size: 320 x 240
Fourcc: h263 Codec: 'H.263'


MOV: Track #1:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=2 dur=230580 lay=0 vol=256
MOV: Media stream!
MOV: Media header!
MOV: Handler header: mhlr/soun ()
MOV: Media info!
MOV: Sound header!
MOV: Handler header: dhlr/alis ()
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: ulaw (20 bytes)
MOV: Sample duration table! (1 blocks)
MOV: Sample->Chunk mapping table! (6 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=10980 ss=1) (ver:0,flags:0)
MOV: Chunk offset table! (7 chunks)
MOV track #1: 7 chunks, 0 samples
pts=10980 scale=8000 time=1,373
==> Found audio stream: 1
Audio bits: 16 chans: 1 rate: 8000
Fourcc: ulaw


Quicktime Clip Info:

Format: Digital Camera
Info: EASTMAN KODAK COMPANY KODAK DX6340 ZOOM DIGITAL CAMERA

MOV: longest streams: A: #1 (7 samples) V: #0 (21 samples)
VIDEO: [h263] 320x240 24bpp 15,301 fps 0,0 kbps ( 0,0 kbyte/s)
[V] filefmt:7 fourcc:0x33363268 size:320x240 fps:15,30 ftime:=0,0654
get_path('sub/') -> '/home/tsdgeos/.mplayer/sub/'
get_path('default.sub') -> '/home/tsdgeos/.mplayer/default.sub'
==========================================================================
Trying to force audio codec driver family libmad...
Opening audio decoder: [alaw] aLaw/uLaw audio decoder
dec_audio: Allocating 2048 + 65536 = 67584 bytes for output buffer.
AUDIO: 8000 Hz, 1 ch, 16 bit (0x10), ratio: 8000->16000 (64,0 kbit)
Selected audio codec: [ulaw] afm:alaw (uLaw)
==========================================================================
X11 opening display: :0.0
vo: X11 color mask: FFFF (R:F800 G:7E0 B:1F)
vo: X11 running at 1024x768 with depth 16 and 16 bpp (":0.0" => local display)
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Detected wm supports ABOVE state.
[x11] Detected wm supports BELOW state.
[x11] Detected wm supports STAYS_ON_TOP state.
[x11] Current fstype setting honours FULLSCREEN STAYS_ON_TOP ABOVE BELOW X
atoms
Disabling DPMS
DPMSDisable stat: 1
It seems there is no Xvideo support for your video card available.
Run 'xvinfo' to verify its Xv support and read DOCS/HTML/en/video.html#xv!
See 'mplayer -vo help' for other (non-xv) video out drivers. Try -vo x11
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
INFO: libavcodec init OK!
Selected video codec: [ffh263] vfm:ffmpeg (FFmpeg H263+ decoder)
==========================================================================
Checking audio filter chain for 8000Hz/1ch/16bit -> 8000Hz/2ch/16bit...
[libaf] Adding filter dummy
[dummy] Was reinitialized, rate=8000Hz, nch = 1, format = 0x00000001 and bps =
2
AF_pre: af format: 2 bps, 1 ch, 8000 hz, little endian signed int
AF_pre: 8000Hz 1ch Signed 16-bit (Little-Endian)
ao2: 8000 Hz 2 chans Signed 16-bit (Little-Endian)
audio_setup: using '/dev/dsp' dsp device
audio_setup: using '/dev/mixer' mixer device
audio_setup: using 'pcm' mixer device
audio_setup: sample format: Signed 16-bit (Little-Endian) (requested: Signed
16-bit (Little-Endian))
audio_setup: using 2 channels (requested: 2)
audio_setup: using 8000 Hz samplerate (requested: 8000)
audio_setup: frags: 16/16 (4096 bytes/frag) free: 65536
AO: [oss] 8000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
AO: Description: OSS/ioctl audio output
AO: Author: A'rpi
Building audio filter chain for 8000Hz/1ch/16bit -> 8000Hz/2ch/16bit...
[dummy] Was reinitialized, rate=8000Hz, nch = 1, format = 0x00000001 and bps =
2
[libaf] Adding filter channels
[channels] Changing number of channels to 2
[dummy] Was reinitialized, rate=8000Hz, nch = 1, format = 0x00000001 and bps =
2
Starting playback...
ds_fill_buffer: EOF reached (stream: audio)
ds_fill_buffer: EOF reached (stream: audio)
[libaf] Reallocating memory in module channels, old len = 0, new len = 43922
[ffmpeg] aspect_ratio: 1,333333
VDec: vo config request - 352 x 288 (preferred csp: Planar YV12)
Trying filter chain: vo
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1,33:1 - prescaling to correct movie aspect.
VO Config (352x288->384x288,flags=4,'MPlayer',0x32315659)
VO: [x11] 352x288 => 384x288 Planar YV12 [zoom]
VO: Description: X11 ( XImage/Shm )
VO: Author: Aaron Holtzman <aholtzma@…>
Sharing memory.
SwScaler?: using unscaled Planar YV12 -> BGR 16-bit special converter
* [vo] Allocating (slices) mp_image_t, 352x288x12bpp YUV planar, 152064
bytes
Unicode font: 458 glyphs.
A: 0,2 V: 0,0 A-V: 0,245 ct: 0,000 1/ 1 ??% ??% ??,?% 0 0 3%
* [vo] Allocating (slices) mp_image_t, 352x288x12bpp YUV planar, 152064
bytes
A: 0,3 V: 0,1 A-V: 0,240 ct: 0,007 2/ 2 ??% ??% ??,?% 0 0 3%
A: 0,4 V: 0,1 A-V: 0,239 ct: 0,013 3/ 3 ??% ??% ??,?% 0 0 3%
A: 0,4 V: 0,2 A-V: 0,239 ct: 0,020 4/ 4 ??% ??% ??,?% 0 0 3%
A: 0,5 V: 0,3 A-V: 0,239 ct: 0,026 5/ 5 ??% ??% ??,?% 0 0 3%
A: 0,6 V: 0,3 A-V: 0,238 ct: 0,033 6/ 6 ??% ??% ??,?% 0 0 2%
A: 0,6 V: 0,4 A-V: 0,240 ct: 0,039 7/ 7 ??% ??% ??,?% 0 0 2%
A: 0,7 V: 0,5 A-V: 0,239 ct: 0,046 8/ 8 ??% ??% ??,?% 0 0 2%
A: 0,8 V: 0,5 A-V: 0,239 ct: 0,052 9/ 9 20% 17% 0,1% 0 0 2%
A: 0,8 V: 0,6 A-V: 0,240 ct: 0,059 10/ 10 18% 15% 0,1% 0 0 1%
A: 0,9 V: 0,7 A-V: 0,238 ct: 0,065 11/ 11 16% 14% 0,1% 0 0 1%
A: 1,0 V: 0,7 A-V: 0,239 ct: 0,072 12/ 12 15% 13% 0,1% 0 0 1%
A: 1,0 V: 0,8 A-V: 0,240 ct: 0,078 13/ 13 15% 12% 0,1% 0 0 1%
A: 1,1 V: 0,8 A-V: 0,239 ct: 0,085 14/ 14 14% 11% 0,1% 0 0 1%
A: 1,2 V: 0,9 A-V: 0,240 ct: 0,092 15/ 15 13% 11% 0,1% 0 0 0%
A: 1,2 V: 1,0 A-V: 0,239 ct: 0,098 16/ 16 12% 10% 0,1% 0 0 0%
A: 1,3 V: 1,0 A-V: 0,239 ct: 0,105 17/ 17 12% 9% 0,0% 0 0 0%
A: 1,4 V: 1,1 A-V: 0,240 ct: 0,111 18/ 18 11% 9% 0,0% 0 0 0%
A: 1,4 V: 1,2 A-V: 0,196 ct: 0,118 19/ 19 11% 9% 0,0% 0 0 0%
A: 1,4 V: 1,2 A-V: 0,131 ct: 0,124 20/ 20 11% 8% 0,0% 0 0 0%
A: 1,4 V: 1,3 A-V: 0,065 ct: 0,131 21/ 21 10% 8% 0,0% 0 0 0%
ds_fill_buffer: EOF reached (stream: video)
A: 1,4 V: 1,3 A-V: 0,065 ct: 0,137 21/ 21 10% 8% 0,0% 0 0 0%
EOF code: 1

Uninit audio filters...
[libaf] Removing filter dummy
[libaf] Removing filter channels
uninit audio: alaw
uninit video: ffmpeg
Successfully enabled DPMS
vo: uninit ...

Exiting... (End of file)

Change History (2)

comment:1 Changed 14 years ago by makovick@…

  • Resolution set to fixed
  • Status changed from new to closed

fixed in cvs

comment:2 Changed 14 years ago by tsdgeos@…

I can still see the black margins with
MPlayer 1.0pre7-4.0.1
is the cvs fix you mention supposed to be here or it will go into mplayer 1.1
or similar?

Note: See TracTickets for help on using tickets.