Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#287 closed defect (fixed)

RealMedia stream becomes garbled after a wile

Reported by: siwilson@… Owned by: r_togni@…
Priority: normal Component: ad
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Initially reported against xbox media center
(http://www.xboxmediaplayer.de/cgi-bin/forums/ikonboard.pl?s=5bf227329cbe20949f752dea3239ab5c;act=ST;f=3;t=12033)
, I also reproduced this problem on a Windows CVS. Windows log attached.

The real media stream initially plays ok, then after while it sounds as though
the packets get mixed up, hard to describe but kind of like an echo, some of the
sound is delayed by about 0.5 sec. Seems to occur more frequently if the network
connection is busy, eg whilst using Bittorrent. If I am using Bittorrent
(consuming about 30-50% of the bandwidth, 512K adsl), the problem usually occurs
almost immediately, other times it might run for an hour or two before it goes
wrong. Real player seems to work ok.

Thanks for a great product!

/Simon

C:\Program Files\MPlayer>mplayer rtsp://rmlivev8.bbc.net.uk/farm/*/ev7/live24
dio1/live/r1_dsat_g2.ra -v
MPlayer dev-CVS-050423-09:41-3.2.3 (C) 2000-2005 MPlayer Team
CPU: Intel Pentium M Banias (Family: 6, Stepping: 5)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetectio

85 audio & 197 video codecs
CommandLine?: 'rtsp://rmlivev8.bbc.net.uk/farm/*/ev7/live24/radio1/live/r1_dsa
2.ra' '-v'
get_path('font/font.desc') -> 'C:/Program Files/MPlayer/mplayer/font/font.des
Font C:/Program Files/MPlayer/mplayer/font/font.desc loaded successfully! (20
hars)
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Using Windows native timing
get_path('input.conf') -> 'C:/Program Files/MPlayer/mplayer/input.conf'
Parsing input config file C:/Program Files/MPlayer/mplayer/input.conf
Input config file C:/Program Files/MPlayer/mplayer/input.conf parsed: 59 bind
get_path('r1_dsat_g2.ra.conf') -> 'C:/Program Files/MPlayer/mplayer/r1_dsat_g
a.conf'
Playing rtsp://rmlivev8.bbc.net.uk/farm/*/ev7/live24/radio1/live/r1_dsat_g2.r
Filename for url is now rtsp://rmlivev8.bbc.net.uk/farm/*/ev7/live24/radio1/l
/r1_dsat_g2.ra
WINSOCK2 init: 0
Filename for url is now rtsp://rmlivev8.bbc.net.uk/farm/*/ev7/live24/radio1/l
/r1_dsat_g2.ra
Resolving rmlivev8.bbc.net.uk for AF_INET...
Connecting to server rmlivev8.bbc.net.uk[212.58.224.95]:554 ...
Cache size set to 8192 KBytes
Connected to server: rmlivev8.bbc.net.uk
CACHE_PRE_INIT: 0 [0] 0 pre:1677721 eof:0
Cache fill: 19.92% (1671168 bytes) Checking for REAL
REAL file format detected.
real: Header size: 18
real: Header object version: 0
real: File version: 0
Chunk: PROP (504f5250) (size: 0x32, offset: 0x12)
First index chunk offset: 0x0
First data chunk offset: 0x152
Flags (2): [perfect play (more buffers)]
Chunk: CONT (544e4f43) (size: 0x49, offset: 0x44)
Chunk: MDPR (5250444d) (size: 0xbb, offset: 0x8d)
Found new stream (id: 0)
Stream description: Audio Stream
Stream mimetype: audio/x-pn-multirate-realaudio-live
==> Found audio stream: 0
Found audio stream!
version: 5
header size: 78
frame_size: 640
sub_packet_size: 128
samplerate: 44100, channels: 2
======= WAVE Format =======
Format Tag: 28515 (0x6F63)
Channels: 2
Samplerate: 44100
avg byte/sec: 44100
Block align: 640
bits/sample: 16
cbSize: 26
Unknown extra header dump: [80] [0] [10] [0] [17] [0] [80] [2] [10] [0] [1] [
[0] [3] [8] [0] [0] [25] [0] [0] [0] [0] [0] [2] [0] [4]
===========================
### skipping 0 bytes of codec info
Chunk: DATA (41544144) (size: 0x0, offset: 0x148)
demux_real: invalid chunksize! (0)
Packets in file: 0
Auto-selected RM audio ID = 0
Clip info:

name: BBC Radio 1
author: BBC
copyright: (C) British Broadcasting Corporation 2004

==========================================================================
Opening audio decoder: [realaud] RealAudio? decoder
opening win32 dll 'cook.so'
Error loading dll
ERROR: Could not open required DirectShow? codec cook.so.
Read the RealAudio? section of the DOCS!
ADecoder preinit failed :(
ADecoder init failed :(
Opening audio decoder: [realaud] RealAudio? decoder
opening win32 dll 'cook.so.6.0'
Error loading dll
ERROR: Could not open required DirectShow? codec cook.so.6.0.
Read the RealAudio? section of the DOCS!
ADecoder preinit failed :(
ADecoder init failed :(
Opening audio decoder: [realaud] RealAudio? decoder
opening win32 dll 'cook3260.dll'
Audio codec: [23] 44 kbps Stereo Music High Response - RA8
Audio bitrate: 44.100 kbit/s (5513 bps)
dec_audio: Allocating 10240 bytes for input buffer.
dec_audio: Allocating 128000 + 65536 = 193536 bytes for output buffer.
AUDIO: 44100 Hz, 2 ch, s16le, 44.1 kbit/3.13% (ratio: 5513->176400)
Selected audio codec: [racookwin] afm:realaud (Win32 RealAudio? COOK)
==========================================================================
Checking audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 44100Hz/2ch/s16le
AF_pre: 44100Hz/2ch/s16le
ao_dsound: Output Devices:
0 Primary Sound Driver <--
1 SoundMAX Digital Audio
2 Bluetooth Audio
ao_dsound: DirectSound? initialized
ao_dsound: Samplerate:44100Hz Channels:2 Format:s16le
ao_dsound: Buffersize:176400 bytes (1000 msec)
ao_dsound: primary buffer created
ao_dsound: secondary (stream)buffer created
AO: [dsound] 44100Hz 2ch s16le (2 bps)
AO: Description: Windows DirectSound? audio output
AO: Author: Gabor Szecsi <deje@…>
Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
Video: no video
Freeing 0 unused video chunks.
Starting playback...
No bind found for key
A: 212.7 (03:32.6) 2.5% 85%

MPlayer interrupted by signal 2 in module: play_audio
Uninit audio filters...
[libaf] Removing filter dummy
uninit audio: realaud
WINSOCK2 uninit
ao_dsound: DirectSound? uninitialized

Change History (8)

comment:1 Changed 14 years ago by mplayer-bugzilla@…

I also get the same affect on FreeBSD 5.4 with MPlayer 1.0pre7-3.4.2 installed
from the port. It only seems to affect "live" streams such as BBC Radio 4.

The command line I use to reproduce the problem is:

mplayer rtsp://rmlivev8.bbc.net.uk/farm/*/ev7/live24/radio4/live/r4_dsat_g2.ra

Originally detected using AlienBBC with a Squeezebox.

comment:2 Changed 14 years ago by gamester17@…

  • Summary changed from Real media stream becomes garbled after a wile to RealMedia stream becomes garbled after a wile

This fix for garbled audio/sound RealAudio? doesn't help does it?;
http://mplayerhq.hu/pipermail/mplayer-dev-eng/2005-October/thread.html#37602
http://mplayerhq.hu/pipermail/mplayer-dev-eng/2005-October/037602.html

...or maybe just the the issue of dropped/missing packets is related to
RealVideo? in RealMedia? video?

comment:3 Changed 14 years ago by gamester17@…

Adding search keywords (for people searching for RealMedia? bugs/issues): Real,
RealNetworks? RealPlayer?, RealVideo?, RealAudio?, RM, RAM, RA, RV, RMVB, live,
live.com

comment:4 Changed 14 years ago by mplayer-bugzilla@…

I have just tested this patch on FreeBSD. The good news is that it
solves the problem for me; thank you!

Incidentally, the Radio 2 listen live feed doesn't work for me at the
moment. I'm guessing the announcement at the head of the feed is
somehow confusing mplayer. All of the other Beeb feeds seem okay.

comment:5 Changed 14 years ago by gamester17@…

Does this "Real demuxer audio cleanup" patch help this issue?:
http://thread.gmane.org/gmane.comp.video.mplayer.devel/30307

comment:6 Changed 14 years ago by diego@…

  • Owner changed from alex@… to r_togni@…

comment:7 Changed 13 years ago by gamester17@…

Has this patch (or a other fix) been implemented in MPlayer's official/public
CVS yet?

comment:8 Changed 13 years ago by r_togni@…

  • Resolution set to fixed
  • Status changed from new to closed

Yes, applied a long time ago.
I'm closing this, if the problem is still thre please repopen it

Note: See TracTickets for help on using tickets.