Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#29 closed enhancement (invalid)

quicktime codecs on win32 loader will load all *.qtx in PATH(s)

Reported by: compn Owned by: alex@…
Priority: normal Component: ad
Version: HEAD Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

the quicktime codecs (actually, this could be version dependent, but i think it happens with all ver qt5, qt6, qt6.3, qt6.5) will load all of the .qtx files in the windows PATH, which makes them load incredibly slowly, and also loads a good 5mb into memory for codecs that arent being used. verified by sascha. possible that timebomb (reza) was working on patching the codec.

workaround: rename/remove .qtx files until needed. this really only affects people with previous quicktime installations (most .qtx files arent included in quicktime codec pack).

note: not an mplayer bug, but a win32loader/quicktime bug.

C:\Documents and Settings\resu\Desktop\wooord>listdlls mplayer|grep qtx

0x676d0000 0x91000 6.05.0000.0048 C:\WINNT\system32\QuickTime?\QuickTime3GPP.qtx
0x66fe0000 0x191000 6.05.0000.0048 C:\WINNT\system32\QuickTime?\QuickTimeAuthoring?.qtx
0x67430000 0x7d000 6.05.0000.0048 C:\WINNT\system32\QuickTime?\QuickTimeEssentials?.qtx
0x66f00000 0xd7000 6.05.0000.0048 C:\WINNT\system32\QuickTime?\QuickTimeInternetExtras?.qtx
0x673c0000 0x6a000 6.05.0000.0048 C:\WINNT\system32\QuickTime?\QuickTimeMPEG.qtx
0x674b0000 0x73000 6.05.0000.0048 C:\WINNT\system32\QuickTime?\QuickTimeMPEG4.qtx
0x66d20000 0xb9000 6.05.0000.0048 C:\WINNT\system32\QuickTime?\QuickTimeStreaming?.qtx
0x672c0000 0x79000 6.00.0002.0010 C:\WINNT\system32\QuickTimeEssentials?.qtx
0x62d70000 0xca000 5.00.0001.0010 C:\WINNT\system32\QuickTimeInternetExtras?.qtx
0x03100000 0x93000 6.05.0001.0017 C:\programs\mplayer\QuickTime3GPP.qtx
0x031b0000 0x79000 6.00.0002.0010 C:\programs\mplayer\QuickTimeEssentials?.qtx
0x03340000 0xca000 5.00.0001.0010 C:\programs\mplayer\QuickTimeInternetExtras?.qtx
0x67800000 0x4c000 6.05.0000.0048 C:\WINNT\system32\QuickTime?\QuickTimeStreamingAuthoring?.qtx
0x67850000 0x1f000 6.05.0000.0048 C:\WINNT\system32\QuickTime?\QuickTimeStreamingExtras?.qtx
0x03540000 0x6c000 1.01.0000.0000 C:\WINNT\system32\QuickTime?\IPIXSupport.qtx
0x66e40000 0x60000 6.05.0000.0048 C:\WINNT\system32\QuickTimeVR.qtx

Change History (1)

comment:1 Changed 14 years ago by saschasommer@…

  • Resolution set to invalid
  • Status changed from new to closed

I would not count this as bug. It is how quicktime works
it needs to load all plugins first to know what they are doing.
It does this via the windows file search function FindFirstFile/FindNextFile?.
Fixing it would mean adding a hack to the loader. For this hack to work
you need to know every plugin that is needed to decode a certain file.
Moreover this hack won't work for the windows port.
Doing a normal setup quicktimeplayer will workaround this by loading itself at
system start.
Your workaround still seems to be the best solution.

Note: See TracTickets for help on using tickets.