Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#294 closed defect (worksforme)

mplayer crashes on first 10 invocations with -vo xvmc -vc ffmpeg12mc

Reported by: tadhunt@… Owned by: ikalvachev@…
Priority: normal Component: vo
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Problem description:

Mplayer with the "-vo xvmc -vc ffmpeg12mc" command line arguments crashes
on the first 10 to 20 invocations immediately after boot.

This problem occurs with:

MPlayer-1.0pre7
MPlayer-CVS as of today

It exits with the error "FATAL: Cannot initialize video driver.",
and then crashes due to a failed assertion.

If I keep trying, it eventually works. Once it starts working, I can
play the video successfully about 5 to 10 times.

Eventually, after a bunch of successful invocations, I end up with
a blue screen and stuttery sound instead of video. As far as I can
tell, once this happens, it's stuck like this forever until I reboot.
Exiting and restarting the X server doesn't fix it.

Also, the "blue screen" output happens, the "-vo xv" output also gives
me the same blue screen, but the sound doesn't stutter.

This problem doesn't seem to be specific to any particular video.

I've provided everything listed in the "how to report
bugs" documentation in the tar file here:

http://www.csh-east.org/tad/mplayer-xvmc-bug.tgz

and I've provided an annotated manifest below.

Please let me know if I can provide any more information, and if you
would like me to try something different.

Thanks,

-Tad Hunt

===============================================================================
Snippit from out/mplayer_output.7256.bad showing the failure:

VO: Description: XVideo Motion Compensation
VO: Author: Ivan Kalvachev <iive@…>

=> FATAL: Cannot initialize video driver.

vo_xvmc: Port 105 grabed
vo_xvmc: Found matching surface with id=54434449 on 105 port at 0 adapter
trying pixfmt=1
* [vo] Allocating (slices) mp_image_t, 1920x1080x0bpp RGB packed, 0 bytes
mplayer: vd_ffmpeg.c:970: mc_get_buffer: Assertion `0' failed.
Only buffers allocated by vo_xvmc allowed



MPlayer interrupted by signal 6 in module: decode_video

  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

===============================================================================
Manifest:

build_info.txt version GCC, LIBC, binutils, etc
config_invocation configuration arguments for mplayer
mplayer_xvmc_invocation mplayer XvMC execution command line
mplayer_xv_invocation mplayer Xv execution command line
cpuinfo.txt /proc/cpuinfo
dmesg.txt dmesg(8) output
os_info.txt Distribution/uname -a
out-*/*.bad output from mplayer for failed invocations
out-*/*.good output from mplayer for successful invocation
out-*/*.blue output from mplayer for "blue screen"
window_manager.txt info about which window manager I'm using
xdpyinfo.txt output from xdpyinfo(1)
Xorg.0.log X server log

================================================================================

Change History (2)

comment:1 Changed 13 years ago by diego@…

  • Owner changed from alex@… to ikalvachev@…

comment:2 Changed 13 years ago by ikalvachev@…

  • Resolution set to worksforme
  • Status changed from new to closed

Many people expirience troubles with making XvMC work on amd_64 systems. All of
these problems are caused by bad NVidia drivers. I believe that the latest
drivers (87.56) should work for most people.
(on unreleated matter 87.56 have strange mode selection behaviour that could
cause choosing an too low vertical refresh. You can find workaround in NVidia forum)

The keycolor-blue overlay bug is also known NVidia bug. I have reported it to
NVidia on multiple occasions and they even claimed to be fixed (changlelog for
53.28 says "Fix a problem where the video overlay would sometimes stop working
when displaying HDTV resolutions.")
As workaround you may try to use blitter surface ("Option" "XvmcUsesTextures?"
"true" in xorg.conf), but be warned it could cause slowdown by exausting
internal videocard bandwidth (happens on gf6600, but i think GF440MX is safe).

Note: See TracTickets for help on using tickets.