Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#326 closed defect (fixed)

Error trying to convert WMV

Reported by: damian77@… Owned by: alex@…
Priority: normal Component: core
Version: 1.0pre7 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Trying to use mencoder with default options I get this message. The file is 20
MB aprox, I cant send it. But is a Microsoft WebCast?.

(In component, I guess)

C:\MPlayer-mingw32-1.0pre7\mplayer>mencoder d.wmv -o a.avi
MEncoder 1.0pre7-3.4.2 (C) 2000-2005 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 9)
Detected cache-line size is 64 bytes
CPUflags: Type: 8 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
File not found: 'frameno.avi'
Failed to open frameno.avi
success: format: 0 data: 0x0 - 0xf74cb3
ASF file format detected.
FATAL: header size bigger than 64 kB (84205)!
Please contact MPlayer authors, and upload/send this file.

Change History (6)

comment:1 Changed 14 years ago by reimar

(In reply to comment #0)

Trying to use mencoder with default options I get this message. The file is

20

MB aprox, I cant send it. But is a Microsoft WebCast?.

Just upload to ftp://mplayerhq.hu/MPlayer/incoming
You don't have to upload all of it if you don't want to, just cancel the upload
any time (preferably upload at least 1 MB though).
If you want to play around yourself you can of course just grab the source and
in asfheader.c remove/modify the hdr_len > 64 * 1024 check.
But I doubt this alone will make it work...

comment:2 Changed 14 years ago by damian77@…

I´ve uploaded the file HeaderSizeBiggerThan64.wmv to
ftp://mplayerhq.hu/MPlayer/incoming

Regards,
Damian.

comment:3 Changed 14 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

(In reply to comment #2)

I´ve uploaded the file HeaderSizeBiggerThan64.wmv to
ftp://mplayerhq.hu/MPlayer/incoming

Aaaah, they put a whole FAQ in the header! In unicode! Just changing the point I
directed a in my last post really fixes it (at least I think so, I'm missing
wmsdmod.dll at the moment)...
Committed a fix to CVS.

comment:4 Changed 14 years ago by damian77@…

Do you know when is going to be a new Windows version with that includes this
fix?

comment:5 Changed 14 years ago by reimar

If we make a LinuxTag? release as intended probably this weekend...

comment:6 Changed 14 years ago by reimar

Maybe one of the builds here can help you out:
http://oss.netfarm.it/mplayer-win32.php

Note: See TracTickets for help on using tickets.