Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#35 closed defect (invalid)

"-vo vesa" -zoom and -fs problems on GeForce2

Reported by: Alexander_Buloichik@… Owned by: saschasommer@…
Priority: important Component: vo
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I have problems with play video in fullscreen mode.
When I try to play video with -fs flag, then mplayer plays it on full screen
without black bands in the top and bottom.
WHen I try to play video with -zoom flag, then mplayer doesn't scale it on the
full screen, and plays like without -zoom flag.
Key 'f' doesn't change fullscreen mode.

On my home computer -fs flag for Radeon VE card works perfectly for "-vo vesa".

OS: Debian/testing, mplayer compiled from CVS.
Kernel : 2.6.7 from kernel.org, devfs
Libc: 2.3.2
gcc version 3.3.4 (Debian 1:3.3.4-3)
GNU ld version 2.14.90.0.7 20031029 Debian GNU/Linux
GNU assembler 2.14.90.0.7 20031029 Debian GNU/Linux

/proc/cpuinfo:
processor : 0
vendor_id : GenuineIntel?
cpu family : 15
model : 2
model name : Intel(R) Pentium(R) 4 CPU 1.80GHz
stepping : 4
cpu MHz : 1795.084
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips : 3547.13

Video : 0000:01:00.0 VGA compatible controller: nVidia Corporation NV11
[GeForce2 MX/MX 400] (rev b2) (prog-if 00 [VGA])

Flags: bus master, 66MHz, medium devsel, latency 248, IRQ 16
Memory at fd000000 (32-bit, non-prefetchable) [size=fe9f0000]
Memory at e8000000 (32-bit, prefetchable) [size=128M]
Expansion ROM at 00010000 [disabled]
Capabilities: <available only to root>

Attachments (3)

nvidia.vesa.-fs-flag.log (175.5 KB) - added by Alexander_Buloichik@… 15 years ago.
Log for -fs flag without indexes.
nvidia.vesa.-zoom-flag.log (179.3 KB) - added by Alexander_Buloichik@… 15 years ago.
Log for -zoom flag without indexes.
vesa.aspect.patch (633 bytes) - added by Alexander_Buloichik@… 15 years ago.
patch for set right aspect ratio on playing with "-fs -vo vesa"

Download all attachments as: .zip

Change History (10)

Changed 15 years ago by Alexander_Buloichik@…

Log for -fs flag without indexes.

comment:1 Changed 15 years ago by Alexander_Buloichik@…

Changed 15 years ago by Alexander_Buloichik@…

Log for -zoom flag without indexes.

comment:2 Changed 15 years ago by Alexander_Buloichik@…

Changed 15 years ago by Alexander_Buloichik@…

patch for set right aspect ratio on playing with "-fs -vo vesa"

comment:3 Changed 15 years ago by Alexander_Buloichik@…

comment:4 Changed 15 years ago by saschasommer@…

  • Status changed from new to assigned

What about -zoom -fs?
I think -zoom only enables the swscaler. While -fs only sets fullscreen
mode.
You need both of them.


comment:5 Changed 15 years ago by saschasommer@…

  • Owner changed from alex@… to saschasommer@…
  • Status changed from assigned to new

comment:6 Changed 15 years ago by reimar

No reply since a long time. If there isn't one very soon, I will close as
"REVOLVED INVALID".

comment:7 Changed 15 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.