Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#411 closed defect (duplicate)

-ao pcm:file= does not handle filenames correctly

Reported by: mplayer@… Owned by: alex@…
Priority: normal Component: ao
Version: 1.0pre7 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

mplayer -ao pcm:file=somepath/"$somevar1" "$somevar2"
produces wrong file to be created if $somevar1 contains a comma.
The filename only contains the string before the comma.

Even tried quoting the string with \" or "\" or \"" without success.

Maybe this is also true for the vo-module (Not tested)

(bash is the shell used for this tries)

When the comma is removed everything is working perfect!

Change History (1)

comment:1 Changed 12 years ago by reimar

  • Resolution set to duplicate
  • Status changed from new to closed

* This bug has been marked as a duplicate of 378 *

Note: See TracTickets for help on using tickets.