Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#414 closed defect (fixed)

mplayer and libfaad2 crashes when playing quicktime movies with aac 5.1 sound

Reported by: vatbier@… Owned by: alex@…
Priority: normal Component: core
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Mandriva Linux 2006 here
I installed

libfaad2_0-2.1-0.20050201.2.1.20060plf
mplayer-1.0-1.pre7.12plf


konsole:
gmplayer http://movies.apple.com/movies/universal/king_kong/king_kong_480p.mov
this works, video and sound play wel: aac 2.0 sound

gmplayer http://movies.apple.com/movies/disney/cars/cars-tsr4_480p.mov
this crashes, aac 5.1 sound
Trying to force audio codec driver family libmad...
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
Segmentation fault

I guess libfaad2 can't deal with aac 5.1 sound.
Where are the makers of libfaad2? Is this the forked version for MPlayer?
Because I read somewhere that faad2 from www.audiocoding.com is not GPL.

vatbier

Change History (1)

comment:1 Changed 13 years ago by dominik@…

  • Resolution set to fixed
  • Status changed from new to closed

The only supported packages are those linked from the Downloads page. Mandriva's
PLF packages are unsupported. With that said, this has already been fixed in CVS
(at least the Cars trailer you mentioned works fine). Closing as FIXED.

Note: See TracTickets for help on using tickets.