Opened 14 years ago

Closed 12 years ago

#415 closed enhancement (fixed)

Player does not display video track from H264 sample movie from Darwin Streaming Server over RTSP.

Reported by: cian.cullinan@… Owned by: alex@…
Priority: normal Component: streaming
Version: HEAD Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Trying to view any of the H264 sample tracks provided with Darwin Streaming
Server - for example sample_h264_1mbit.mp4 - via rtsp
(rtsp://localhost/sample_h264_1mbit.mp4) results in audio being played, but no
video. The relevant error message from the console output seems to be:
Unknown MPlayer format code for MIME type "video/H264"
This stream plays fine using VLC.

Change History (6)

comment:1 Changed 14 years ago by cian.cullinan@…

  • Resolution set to fixed
  • Status changed from new to closed

OK, on further inspection of demux_rtp_codec.cpp it seems like H264 over RTSP
just isn't supported yet.

comment:2 Changed 14 years ago by cian.cullinan@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:3 Changed 14 years ago by cian.cullinan@…

  • Severity changed from normal to enhancement

Reopening this as a feature request. Here is a sample:
rtsp://gurke.bootlab.org/casah264.mp4

comment:4 Changed 14 years ago by cian.cullinan@…

  • Component changed from vo to streaming

comment:5 Changed 12 years ago by compn

should be fixed in svn, pls check.

comment:6 Changed 12 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from reopened to closed

This feature was added in r22869.
Please report non-working streams that everybody can access on the mailing list.
Carl Eugen

Note: See TracTickets for help on using tickets.