Opened 13 years ago

Last modified 9 years ago

#497 closed defect (fixed)

Incorrect genre tags displayed

Reported by: delmonico@… Owned by: reimar
Priority: normal Component: demuxer
Version: 1.0pre7 Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

There is a bug in the genre list that will display some genres incorrectly
(e.g. "Southern Rock" instead of "Comedy") when playing MP3 files with ID3 meta
informatio. This is due to wrong Int<>String assignment in
libmpdemux/genres.h.new

Genre list taken from the ID3 specifcation: http://www.id3.org/id3v2-00.txt
Reformatted with sed: sed s/" *\([0-9]*\)\.\(.*\)"/"\"\2\",\t\t\t\t\/* \1
*\/"/g

See attachment for a fix. Thanks for this awesome piece of software. cheers,
Christoph

Attachments (1)

genres.diff (596 bytes) - added by delmonico@… 13 years ago.
Patch for libmpdemux/genres.h, against version 1.0pre7try2

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by delmonico@…

Patch for libmpdemux/genres.h, against version 1.0pre7try2

comment:1 Changed 13 years ago by delmonico@…

comment:2 Changed 9 years ago by compn

  • Owner changed from r_togni@… to reimar

comment:3 Changed 9 years ago by compn

  • Resolution set to fixed
  • Status changed from new to closed, patriotact@gmail.com

this must have been applied somewhen.

Note: See TracTickets for help on using tickets.