Opened 13 years ago

Closed 12 years ago

Last modified 10 years ago

#535 closed defect (invalid)

unable to compile on solaris 11 (Nevada) x86

Reported by: jdh13@… Owned by: diego@…
Priority: normal Component: build system
Version: 1.0pre8 Severity: normal
Keywords: Cc: reimar, attila@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

tested with 1.0pre8 and the subversion release
my config: dell laptop d400, solaris nevada build 40 (aka solaris 11)

./configure --with-codecsdir=/home/test/essential-20060611/
--prefix=/home/test/mplayer-dev
...
then
gmake | & tee MAKE.LOG
...
gcc: unrecognized option `-rdynamic'
Undefined first referenced

symbol in file

libiconv_close mp_msg.o (symbol belongs to implicit
dependency /opt/csw/lib/libiconv.so.2)
libiconv_open mp_msg.o (symbol belongs to implicit
dependency /opt/csw/lib/libiconv.so.2)
libiconv mp_msg.o (symbol belongs to implicit
dependency /opt/csw/lib/libiconv.so.2)
ld: fatal: Symbol referencing errors. No output written to mplayer

this probleme seems to be related to:
http://mapserver.gis.umn.edu/bugs/show_bug.cgi?id=1017
i.e., configure detects iconv in libc, but use iconv in /opt/csw/lib at compile time

so, i deleted mp_msg.o, modified manually the compile line, suppressing
-L/opt/csw/lib:
gcc -c -I../libvo -I../../libvo -fno-PIC -O4 -march=pentium-m -mtune=pentium-m
-pipe -ffast-math -fomit-frame-pointer -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -I. -I/opt/csw/include/freetype2 -I/opt/csw/include/SDL
-D_REENTRANT -I./libavutil -I./libavcodec -o mp_msg.o mp_msg.c

then re-did a gmake. Others files needed the same actions:
subreader.o
font_load_ft.o
mp_msg-mencoder.o

After that, mplayer compile fine

There are 2 problems yet:
-rdynamic instead of -Bdynamic
i looked at:
http://solarisopen.wordpress.com/2006/04/30/mplayer-solaris-x86/
but it seems that nobody corrected it

and make install, when you try to install without being root:
% gmake install
install -d /home/test/mplayer/bin
install -m 755 -s mplayer /home/test/mplayer/bin/mplayer
find: stat() error /home/test/mplayer/bin/mplayer: No such file or directory
find: cannot follow symbolic link /bin/jcontrol: No such file or directory
find: cannot follow symbolic link /usr/bin/jcontrol: No such file or directory
find: cannot read dir /etc/inet/secret: Permission denied
find: cannot read dir /etc/flash/postcreation: Permission denied
find: cannot read dir /etc/flash/precreation: Permission denied
find: cannot read dir /etc/flash/preexit: Permission denied
find: stat() error /etc/flash/postdeployment/cleanup-scn-base: Permission denied
find: cannot read dir /etc/sfw/private: Permission denied
find: cannot read dir /etc/sfw/openssl/private: Permission denied
find: cannot read dir /etc/apache/ssl.key: Permission denied
find: cannot read dir /etc/webmin: Permission denied
find: cannot follow symbolic link /usr/lib/locale/es_MX.UTF-8/LC_MESSAGES: No
such file or directory
find: cannot follow symbolic link /usr/lib/locale/fr_CA.UTF-8/LC_MESSAGES: No
such file or directory
find: cannot read dir /usr/lib/cc-cfw: Permission denied
find: cannot read dir /usr/lib/scn/bin: Permission denied
find: cannot read dir /usr/lib/scn/lib: Permission denied
install: mplayer was not found anywhere!
gmake: * [install] Error 2

Change History (7)

comment:1 Changed 13 years ago by lostpassword@…

  • Summary changed from unable to compile on solaris 11 (Nevada) x86 to unable to compile on solaris 11 (Nevada) x86

Can you try compiling 1.0rc1 and tell me if you have any luck?
I have opened another for MPlayer under solaris 11

Bug 627

comment:2 Changed 12 years ago by diego@…

  • Status changed from new to assigned

Can you report back whether this is still a problem? There have been a multitude of changes since this bug report was filed.

comment:3 Changed 12 years ago by jdh13@…

(In reply to comment #2)

Can you report back whether this is still a problem? There have been a
multitude of changes since this bug report was filed.

yakari-henry% pwd
/home/henry/MPlayer-1.0rc1
yakari-henry% ./configure --with-codecsdir=/home/henry/essential-20060611 --prefix=/home/henry/mplayer-dev
Detected operating system: SunOS
Detected host architecture: i386
Checking for cc version ... not found
Checking for gcc version ... 3.4.3, ok
Checking for host cc ... gcc
Checking for cross compilation ... no
Checking for CPU vendor ... GenuineIntel? (6:13:6)
Checking for CPU type ... Intel(R) Pentium(R) M processor 1.80GHz
Checking for GCC & CPU optimization abilities ... pentium-m
Checking for kernel support of mmx ... yes
Checking for kernel support of mmxext ... yes
Checking for kernel support of sse ... yes
Checking for kernel support of sse2 ... yes
Checking for mtrr support ... yes
Checking for assembler support of -pipe option ... yes
Checking for compiler support of named assembler arguments ... yes
Checking for assembler (/usr/sfw/bin/gas ) ... ok
Checking for .align is a power of two ... no
Checking for MPlayer binary name ... mplayer
Checking for extra headers ... none
Checking for extra libs ... none
Checking for -lposix ... no
Checking for -lm ... yes
Checking for langinfo ... yes
Checking for language ... using en (man pages: en)
Checking for enable sighandler ... yes
Checking for runtime cpudetection ... no
Checking for restrict keyword ... restrict
Checking for
builtin_expect ... yes
Checking for kstat ... yes
Checking for posix4 ... yes
Checking for lrintf ... yes
Checking for round ... yes
Checking for nanosleep ... yes
Checking for socklib ... yes (using -lsocket -lnsl)
Checking for inet_pton() ... yes (using -lsocket -lnsl)
Checking for inttypes.h (required) ... yes
Checking for int_fastXY_t in inttypes.h ... yes
Checking for word size ... 32
Checking for stddef.h ... yes
Checking for malloc.h ... yes
Checking for memalign() ... yes
Checking for alloca.h ... yes
Checking for mman.h ... yes
Checking for dynamic loader ... yes
Checking for dynamic a/v plugins support ... no
Checking for pthread ... yes (using )
Checking for rpath ... no
Checking for iconv ... yes
Checking for sys/soundcard.h ... yes
Checking for sys/dvdio.h ... no
Checking for sys/cdio.h ... yes
Checking for linux/cdrom.h ... no
Checking for dvd.h ... no
Checking for userspace SCSI headers (Solaris) ... yes
Checking for termcap ... yes (using -ltermcap)
Checking for termios ... yes (using sys/termios.h)
Checking for shm ... yes
Checking for linux devfs ... no
Checking for scandir() ... yes
Checking for strsep() ... no
Checking for strlcpy() ... yes
Checking for strlcat() ... yes
Checking for fseeko() ... yes
Checking for localtime_r() ... yes
Checking for vsscanf() ... yes
Checking for swab() ... yes
Checking for POSIX select() ... yes
Checking for gettimeofday() ... yes
Checking for glob() ... yes
Checking for setenv() ... yes
Checking for sysi86() ... yes
Checking for sys/sysinfo.h ... yes
Checking for Samba support (libsmbclient) ... yes
Checking for 3dfx ... no
Checking for tdfxfb ... no
Checking for s3fb ... no
Checking for tdfxvid ... no
Checking for tga ... yes
Checking for DirectFB ... ./configure: syntax error at line 3756: `_dfb_version=$' unexpected

comment:4 Changed 12 years ago by diego@…

(In reply to comment #3)

(In reply to comment #2)

Can you report back whether this is still a problem? There have been a
multitude of changes since this bug report was filed.

yakari-henry% pwd
/home/henry/MPlayer-1.0rc1
yakari-henry% ./configure --with-codecsdir=/home/henry/essential-20060611
--prefix=/home/henry/mplayer-dev
Detected operating system: SunOS
[...]
Checking for DirectFB ... ./configure: syntax error at line 3756:
`_dfb_version=$' unexpected

You are using Solaris stone age tools, replace the crap shell with a POSIX-compliant one.

comment:5 Changed 12 years ago by jdh13@…

You are using Solaris stone age tools, replace the crap shell with a
POSIX-compliant one.

yes, thanks for pointing me the right thing to do :)
ok, so using "bash configure ..." is better
but as i said in my first post, there are always problem with iconv, with
"gcc: unrecognized option `-rdynamic'", and with others things...
And now, the compilation failed, at here:
Undefined first referenced

symbol in file

read_toc stream/stream.a(stream_cddb.o)
ld: fatal: Symbol referencing errors. No output written to mplayer

i saw in stream/stream_cddb.c that you have:

#if defined(linux)
defined(bsdi)

int
read_toc(const char *dev) {
...

so it seems that it lacks read_toc definition when system as solaris are used

comment:6 Changed 12 years ago by reimar

  • Cc Reimar.Doeffinger@… added
  • Resolution set to invalid
  • Status changed from assigned to closed

You are supposed to use latest SVN before reporting bugs for a good reason. This particular problem has been fixed almost a year ago, though cddb still won't work on Solaris it should now always compile fine.

comment:7 Changed 10 years ago by attila@…

  • Cc attila@… added
Note: See TracTickets for help on using tickets.