Opened 13 years ago

Last modified 9 years ago

#537 closed defect (duplicate)

crash with -vo xv output on playing a large WMV file (with win32 DLL)

Reported by: stranche@… Owned by: reimar
Priority: normal Component: vo
Version: 1.0pre8 Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

when trying to play this video
http://rd.yahoo.co.jp/tokushu/5cm/teaser01/?http://i.yimg.jp/images/evt/5cm/teaser8000k1280_720.wmv
I get the following :

$ mplayer Desktop/teaser8000k1280_720.wmv
MPlayer 1.0pre8-4.0.3 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz (Family: 15, Model: 3,
Stepping: 4)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup
scripts.

Playing Desktop/teaser8000k1280_720.wmv.
ASF file format detected.
VIDEO: [WMV2] 1280x720 24bpp 1000.000 fps 0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16002->176400)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================
==========================================================================
Opening video decoder: [dshow] DirectShow? video codecs
Decoder supports the following YUV formats: YUY2 IYUV UYVY YV12 YVYU I420 YVU9
Decoder is capable of YUV output (flags 0x7f)
VDec: vo config request - 1280 x 720 (preferred colorspace: Packed YUY2)
[PP] Using codec's postprocessing, max q = 4.
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 1280x720 => 1280x720 Planar YV12
Selected video codec: [wmv8] vfm: dshow (Windows Media Video 8)
==========================================================================
AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)
Starting playback...
X11 error: BadAlloc? (insufficient resources for operation)?,?% 0 0

MPlayer interrupted by signal 6 in module: vo_check_events

  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

playing with -vo x11, -vo gl and -vo gl2 works (but of course is slow)

distro is Ubuntu 6.06 (up to date)
CPU is Intel(R) Pentium(R) 4 CPU 2.80GHz
chipset is Intel i915 (82915G/GV/910GL Express Chipset)

Attachments (1)

output.txt (7.8 KB) - added by stranche@… 13 years ago.
output done by mplayer -v

Download all attachments as: .zip

Change History (6)

comment:1 Changed 13 years ago by beastd

(In reply to comment #0)

Hi,

when trying to play this video
http://rd.yahoo.co.jp/tokushu/5cm/teaser01/?http://i.yimg.jp/images/evt/5cm/

teaser8000k1280_720.wmv

I get the following :

[skip mplayer output]

playing with -vo x11, -vo gl and -vo gl2 works (but of course is slow)

distro is Ubuntu 6.06 (up to date)
CPU is Intel(R) Pentium(R) 4 CPU 2.80GHz
chipset is Intel i915 (82915G/GV/910GL Express Chipset)

The problem is probably reaching the limitation of the video hardware.

Maybe a space problem. Generally your card seems to be support that
high resulotion but at the moment you want to play the video there
aren't enough resources available which can depend on different things i think.

You can try to software scale down the image before it gets to th xv video

output module; you can use the scale video filter for that (look it up in
the mplayer manpage). It will be slower but may still be better then using
one of the other VOs.

I am planning to analyze the situation more closely as nowadays more and more

of these probems seem to pile up.

Changed 13 years ago by stranche@…

output done by mplayer -v

comment:2 Changed 13 years ago by stranche@…

comment:3 Changed 13 years ago by stranche@…

(In reply to comment #1)
problem still remains on 1.0rc1

I join a more complete output done with mplayer -v

comment:4 Changed 9 years ago by compn

  • Owner changed from beastd to reimar

comment:5 Changed 9 years ago by compn

  • Resolution set to duplicate
  • Status changed from new to closed, patriotact@gmail.com

.

Note: See TracTickets for help on using tickets.