Opened 13 years ago

Last modified 8 years ago

#614 closed defect (worksforme)

Mplayer crashed when played short movie with sound

Reported by: beetlegreen@… Owned by: reimar
Priority: normal Component: GUI
Version: 1.0rc1 Severity: critical
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I have a new Compaq tc4200 Centrino Mobile laptop computer running Window XP
Tablet PC Edition version 5.1 Service Pack 2. I installed "MPlayer-1.0rc1-
gui" today with "Blue" or "Phony" skins. When I played a short movie 1.4 MB
with very little sound, it worked fine. When I played another short movie
1.2MB with sound,I got Mplayer GUI for Windows Errors -> First "Mplayer
interrupted by signal 11 in module: init_audio_codec"; second "-MPlayer
crashed by Bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug
and make 'gdb' backtrace and disassembly. Details in
DOCS/HTML/en/bugreports_what.html#bugreports_crash."; then "-MPlayer crashed.
This shouldn't happen. It can be a bug in the MPlayer code _or_in your
drivers _or_in your gcc version. If you think it's MPlayer's fault, please
read DOCS/HTML/en/bugreports.html and follow the instruction there. We can't
and won't help unless you provide this information when reporting a possible
bug." When I clicked "OK", the MPlayer disappeared on my screen. I can play
both movies on VLC media player no problem. Please help.

Change History (11)

comment:1 Changed 13 years ago by reimar

  • op_sys changed from Other to MinGW

Follow the steps in http://www.mplayerhq.hu/DOCS/HTML/en/bugreports_what.html ,
or as a absolute minimum give us an URL where to download the problematic file
or upload it to ftp://upload.mplayerhq.hu/MPlayer/incoming .

comment:2 Changed 13 years ago by beetlegreen@…

I downloaded the files from
http://www.mplayerhq.hu/homepage/design7/dload.html Mplayer 1.0rc1 Windows GUI
using HTTP US "MPlayer-1.0rc1-gui.zip"; and Blue version 1.6 "Blue-
1.6.tar.tar" and Phony version 1.1 "phony-1.1.tar.tar" from www. Thank you.

comment:3 Changed 13 years ago by reimar

The problematic _video_ file, not the MPlayer files...

comment:4 Changed 13 years ago by beetlegreen@…

I tried a few more viedo files that work at both VLC Media player and Microsoft
media player, they just didn't work on MPlayer. Unfortunately, they are too
big to attach as attachments.

comment:5 Changed 13 years ago by reimar

That's why I asked to upload them to
ftp://upload.mplayerhq.hu/MPlayer/incoming, there is enough room there. Also
the video you mentioned in the original report is only 1.2 MB large, which I
think is not too large to attach here.

comment:6 Changed 13 years ago by beetlegreen@…

I just ftped 2 movies to the ftp://upload.mplayerhq.hu/MPlayer/incoming.
staff_meeting_training.wmv works at MPlayer, but NewCarForWoman?.wmv didn't.
Both movies work at VLC Player and Microsoft Media Player. Thank you.

comment:7 Changed 13 years ago by reimar

Hm. Weird. I can not reproduce the problem, neither on Linux nor W2k3 server.

comment:8 Changed 13 years ago by beetlegreen@…

Do you mean both movies work ok in your system? Should I re-download and re-
setup the MPlayer?

comment:9 Changed 13 years ago by reimar

Yes, both movies play for me, and no, I don't really think that re-downloading
MPlayer will help. I currently have no idea what the problem could be. Might
try to change some setting though, esp. the video and audio output methods.
That's the best I can suggest right now.

comment:10 Changed 13 years ago by beetlegreen@…

I re-downloaded the "MPlayer-1.0rc1-gui.zip" and "Blue-1.6.tar.tar" in my
laptop. It is a Sony VAIO VGN-A250 runing Window XP Home Edition Version 5.1
with Service Pack 2. I set up mplayer in C drive. I put "blue" into
C:\mplayer\mplayer\skins. I saw the exactly problem as the other computer. I
believe I need to change some settings but don't know how and what to change.
Please advise.

comment:11 Changed 8 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed, patriotact@gmail.com

probably mplayer compiled for a cpu that was not your own.
use svn, works for me, etc

Note: See TracTickets for help on using tickets.