Opened 13 years ago

Closed 8 years ago

#641 closed enhancement (fixed)

add karaoke support, cdg kar

Reported by: compn Owned by: reimar
Priority: normal Component: vf
Version: HEAD Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

add karaoke support to mplayer

needs demuxers for cdg and kar formats
some karaoke formats have styles so maybe add it to libass?

sample cdg uploaded to incoming/karaoke

Change History (3)

comment:1 Changed 13 years ago by compn

  • Summary changed from add karaoke support, cdg kar to add karaoke support, cdg kar

uploaded .kar samples to incoming/karaoke - kar - midi

kar seems to be a text track in the midi container. so midi support would be
needed in mplayer as well.

MIDI Karaoke File (.KAR) Format

MIDI-Karaoke (which uses the ".kar" file extension) files are an "unofficial"
extension of MIDI files, used to add synchronized lyrics to standard MIDI files.

http://www.jbum.com/cdg_revealed.html has some info on cdg

comment:2 Changed 10 years ago by compn

also see this report about cdg+kar in .zip
http://www.xbmc.org/trac/ticket/5549

comment:3 Changed 8 years ago by compn

  • Resolution set to fixed
  • Status changed from new to closed

cdg was added to ffmpeg and mplayer a while back, so closing this issue.
the kar (aka midi) issue i'll leave to the 'native mod' bug.

Note: See TracTickets for help on using tickets.