Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#647 closed defect (wontfix)

MPlayer rc1 can't be properly scaled by WM on start

Reported by: arrenlex+mplayer@… Owned by: reimar
Priority: normal Component: core
Version: 1.0rc1 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I have my window manager (kwin) set up to automatically maximise mplayer-xv
windows. This worked great up to mplayer1.0pre8. I installed mplayer-rc1 and now
the resizing doesn't work -- the window snaps back to the movie size. What might
have caused this? What might have changed? I can still resize the window
manually afterward. I would have regression-tested, but exactly none of the
intermittent svn checkouts compile on my system: make crashes with
../libavcodec/avcodec.h:34:20: error: avutil.h: No such file or directory

I want to add that mplayer with other video drivers (gl, gl2, x11..) always had
this problem: the windows snapped back to movie size. Xv was the only one that
worked, until recently.

mplayer without a gui, on KDE, on Debian etch, on x86, compiling with gcc 4.1.2
without any configure switches. /proc/cpuinfo lists 'sse', 'mmx', and '3dnow' in
the flags; don't know if that's relevant.

P.S. no, I don't want to use fullscreen instead. I like having a taskbar
visible, and the ability to resize the window at need. It's not nearly as
convenient.

Change History (1)

comment:1 Changed 13 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

I think this change was needed to fix -geometry. Fixing stuff is incredibly
hard because there is zero consistency in how different window managers behave.
The best I can advice is to use -geometry to make the window the right size.
Btw. by setting -fstype right, fullscreen mode (assuming the window manager
supports the right fstypes) should not cover the taskbar, at least it doesn't
by default on ubuntu (which annoys me incredibly).

Note: See TracTickets for help on using tickets.