Opened 12 years ago

Last modified 9 years ago

#740 closed defect (fixed)

MPlayer's warning messages disable DPMS and Screensaver, permanently.

Reported by: f.alabas@… Owned by: reimar
Priority: normal Component: core
Version: 1.0rc1 Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I am using MPlayer on my opensuse 10.2 installed AMD64 laptop machine. It works very good on my KDE desktop. In case of an "unavailable codec/or unsupported video format" it gives usual/normal warning messages. That's ok. However "ONLY" after having this kind of warning messages, MPlayer permanently disables DPMS and Screensaver after exiting from MPlayer application. Then, in order to make the DPMS and Screensaver work again, I need to exit from kpowersave and launch kpowersave again.

I tried to reproduce the same issue with kaffeine or xine, but after having the same type warning messages they do not disturb DPMS and Screensaver after exit.

My estimation is that Mplayer does not send a proper feedback to operating system upon existence of an error.

Change History (1)

comment:1 Changed 9 years ago by compn

  • Resolution set to fixed
  • Status changed from new to closed, patriotact@gmail.com

could be because of stop-xscreensaver not being reset after mplayer crashes or some dumb thing. use -heartbeat-cmd instead.

Note: See TracTickets for help on using tickets.