Opened 13 years ago

Closed 12 years ago

#779 closed defect (invalid)

ao alsa surround hogs device

Reported by: eternalsword@… Owned by: reimar
Priority: normal Component: ao
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Two methods to reproduce

First method

  1. Open up a file with either AC3 or DTS surround
  2. Pause mplayer
  3. Attempt to play some music in your favorite player - it should complain in some manner about not being able to open the device.

Second method

  1. Play some music in your favorite player
  2. Pause the music
  3. Open up a file with either AC3 or DTS surround - should get an error like the following

[AO_ALSA] alsa-lib: pcm_hw.c:1246:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or resource busy

gstramer plays back the surround file just fine (using method 2), so it appears to not be a matter of alsa messing up.

Change History (1)

comment:1 Changed 12 years ago by eternalsword@…

  • Resolution set to invalid
  • Status changed from new to closed

I got some help from the #alsa channel on freenode. Turns out I needed to modify my .asoundrc and add 6 channel dmix support there.

Note: See TracTickets for help on using tickets.