Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#81 closed defect (worksforme)

Screen goes blank between files while playing from playlist using the GUI.

Reported by: witerabit0r@… Owned by: reimar
Priority: normal Component: GUI
Version: 1.0pre5 Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Pretty much just that. While watching things on a playlist, when it gets to the
next file on the list, the screen goes blank. The next file does actually play
(audio is playing) and the video can be brought back by right clicking the mouse.

Obviously nothing urgent, would just be nice to have it resolved so I don't have
to get up between cartoons. :D

I apologise if this has already been resolved, but my incompetent searching
skills couldn't bring up anything similar.

Change History (8)

comment:1 Changed 15 years ago by witerabit0r@…

Sorry. I just realise I didn't add anything techincal at all (not that I know
much, anyway... but I'm sure every little bit helps...)

I'm running Fedora Core 2 with the 2.6.8-1.521 kernel on a Athlon 2400+ and a
MX400 graphics card. X server is KDE.

comment:2 Changed 15 years ago by rajil.saraswat@…

I can confirm that too on an Athlon-XP box using xorg with render on.

#glxinfo|grep render
direct rendering: Yes
OpenGL renderer string: GeForce4 MX 440/AGP/SSE/3DNOW!

This is with MPlayer dev-CVS-041003-19:19-3.3.4 (C) 2000-2004 MPlayer Team,
also with 1.0-pre5
window manager is kde again. This is what comes up on running mplayer

MPlayer dev-CVS-041003-19:19-3.3.4 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon 4 /Athlon MP/XP Palomino 1667 MHz (Family:
6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Reading config file /tmp/local/etc/mplayer/mplayer.conf: No such file or
directory
Reading config file /home/user/.mplayer/config
[cfg] read config file: /home/user/.mplayer/gui.conf
Reading config file /home/user/.mplayer/gui.conf
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Reading /home/user/.mplayer/codecs.conf: Can't open
'/home/user/.mplayer/codecs.conf': No such file or directory
Reading /tmp/local/etc/mplayer/codecs.conf: Can't open
'/tmp/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /home/user/.mplayer/font/font.desc
font: can't open file: /tmp/local/share/mplayer/font/font.desc
Failed to open /dev/rtc: No such file or directory (it should be readable by
the user.)
Using nanosleep() timing
Can't open input config file /home/user/.mplayer/input.conf: No such file or
directory
Can't open input config file /tmp/local/etc/mplayer/input.conf: No such file
or directory
Falling back on default (hardcoded) input config
Setting up LIRC support...
SKIN dir 1: '/home/user/.mplayer/Skin'
SKIN dir 2: '/tmp/local/share/mplayer/Skin'
cmd: 20

Playing /mnt/xp/mov/Great_Remix_Video/7-X_Mix.mpg.
Cache fill: 0.00% (0 bytes) MPEG-PS file format detected.
VIDEO: MPEG1 352x288 (aspect 8) 25.000 fps 1123.2 kbps (140.4 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 28000->176400 (224.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 352 x 288 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
==========================================================================
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 44100Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
Starting playback...
VDec: vo config request - 352 x 288 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 352x288 => 384x288 Planar YV12ected video codec: [mpeg12]
vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))

comment:3 Changed 15 years ago by reimar

No idea what causes this, but please try -fixed-vo (it sometimes has other ugly
sideeffects, but anyway...)

comment:4 Changed 15 years ago by jdavin@…

  • Priority changed from unimportant to normal

I also have this same exact problem.

System is Fedora Core 3 with kernel 2.6.8-1.521smp.

Version info:
MPlayer 1.0pre6-3.3.3 (C) 2000-2004 MPlayer Team

Since this bug appears to exist in all versions of mplayer (and has existed for
at least 6 months on the versions I've used), and should be an easy bug for an
mplayer team member to fix, it'd be great if this gets prioritized soon.

comment:5 Changed 15 years ago by ellingsw@…

I have noticed this behavior as well but would like to add more.

When playing any video double sized, MPlayer always switches back to normal size
and places the video window in the upper left corner of the display when it
starts playing the next file in the play list. Selecting double size from the
pop-up menu puts MPlayer back into double sized mode but again it switches back
to normal size when playing the next file in the play list.

I believe these two problems are related.

I run Gentoo and this has occurred on every verison of MPlayer I have compiled
and installed. Here is a list of every MPlayer build I have installed on my
machine:

$> genlop mplayer

  • media-video/mplayer

Tue Apr 15 12:51:44 2003 >>> media-video/mplayer-0.90_rc5
Fri Jun 27 01:24:01 2003 >>> media-video/mplayer-0.90_rc5
Tue Jul 22 10:35:03 2003 >>> media-video/mplayer-0.90-r2
Mon Sep 15 03:29:59 2003 >>> media-video/mplayer-0.91
Mon Sep 29 10:26:17 2003 >>> media-video/mplayer-0.92
Sun Mar 28 04:43:26 2004 >>> media-video/mplayer-0.92
Wed Apr 21 17:22:26 2004 >>> media-video/mplayer-0.92-r1
Fri May 28 23:59:35 2004 >>> media-video/mplayer-1.0_pre4
Mon Aug 2 09:22:23 2004 >>> media-video/mplayer-1.0_pre4-r7
Thu Oct 21 21:09:17 2004 >>> media-video/mplayer-1.0_pre4-r7
Thu Oct 21 22:10:09 2004 >>> media-video/mplayer-1.0_pre4-r7
Wed Nov 10 00:48:02 2004 >>> media-video/mplayer-1.0_pre4-r7
Wed Nov 17 22:25:03 2004 >>> media-video/mplayer-1.0_pre4-r7
Wed Nov 24 09:16:40 2004 >>> media-video/mplayer-1.0_pre4-r7
Sun Dec 26 23:05:56 2004 >>> media-video/mplayer-1.0_pre5-r5
Fri Feb 4 00:15:44 2005 >>> media-video/mplayer-1.0_pre5-r5
Thu May 5 13:06:54 2005 >>> media-video/mplayer-1.0_pre6-r4
Sat May 7 14:36:03 2005 >>> media-video/mplayer-1.0_pre6-r4


Here is the console output from running 'gmplayer -quiet *.mpg' on a series of
MPEGs generated by Electric Sheep in fullscreen:

MPlayer 1.0pre6-3.3.5-20050130 (C) 2000-2004 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
xscreensaver_disable: xscreensaver wid=8388616.
77 audio & 189 video codecs
Playing /home/electro/.sheep/19108=19095=19080.mpg.
Cache fill: 0.00% (0 bytes) MPEG-ES file format detected.
VIDEO: MPEG2 640x480 (aspect 2) 30.000 fps 9000.0 kbps (1125.0 kbyte/s)
xscreensaver_disable: xscreensaver wid=8388616.
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 640 x 480 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Audio: no sound
Starting playback...
VDec: vo config request - 640 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 640x480 => 640x480 Planar YV12

Playing /home/electro/.sheep/19110=19066=19109.mpg.
Cache fill: 18.75% (1572864 bytes) MPEG-ES file format detected.
VIDEO: MPEG2 640x480 (aspect 2) 30.000 fps 9000.0 kbps (1125.0 kbyte/s)
xscreensaver_disable: xscreensaver wid=8388616.
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 640 x 480 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Audio: no sound
Starting playback...
VDec: vo config request - 640 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 640x480 => 640x480 Planar YV12

Playing /home/electro/.sheep/19111=19109=19061.mpg.
Cache fill: 16.60% (1392640 bytes) MPEG-ES file format detected.
VIDEO: MPEG2 640x480 (aspect 2) 30.000 fps 9000.0 kbps (1125.0 kbyte/s)
xscreensaver_disable: xscreensaver wid=8388616.
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 640 x 480 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Audio: no sound
Starting playback...
VDec: vo config request - 640 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 640x480 => 640x480 Planar YV12 [fs]

Playing /home/electro/.sheep/19113=19085=19112.mpg.
Cache fill: 19.82% (1662976 bytes) MPEG-ES file format detected.
VIDEO: MPEG2 640x480 (aspect 2) 30.000 fps 9000.0 kbps (1125.0 kbyte/s)
xscreensaver_disable: xscreensaver wid=8388616.
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 640 x 480 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Audio: no sound
Starting playback...
VDec: vo config request - 640 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 640x480 => 640x480 Planar YV12 [fs]

Playing /home/electro/.sheep/19114=19112=19070.mpg.
Cache fill: 0.00% (0 bytes) MPEG-ES file format detected.
VIDEO: MPEG2 640x480 (aspect 2) 30.000 fps 9000.0 kbps (1125.0 kbyte/s)
xscreensaver_disable: xscreensaver wid=8388616.
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 640 x 480 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Audio: no sound
Starting playback...
VDec: vo config request - 640 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 640x480 => 640x480 Planar YV12 [fs]

Playing /home/electro/.sheep/19115=19112=19090.mpg.
Cache fill: 6.64% (557056 bytes) MPEG-ES file format detected.
VIDEO: MPEG2 640x480 (aspect 2) 30.000 fps 9000.0 kbps (1125.0 kbyte/s)
xscreensaver_disable: xscreensaver wid=8388616.
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 640 x 480 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Audio: no sound
Starting playback...
VDec: vo config request - 640 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 640x480 => 640x480 Planar YV12 [fs]

Exiting... (Exit)


comment:6 Changed 15 years ago by reimar

(In reply to comment #4)

Since this bug appears to exist in all versions of mplayer (and has existed for
at least 6 months on the versions I've used), and should be an easy bug for an
mplayer team member to fix, it'd be great if this gets prioritized soon.

Well, it would help if somebody would answer my question (whether -fixed-vo helps).
Also you should try latest CVS and the new -vo xv suboptions (ck=... etc., see
the man page)

comment:7 Changed 14 years ago by diego@…

  • Component changed from vo to GUI
  • Owner changed from alex@… to Reimar.Doeffinger@…

comment:8 Changed 14 years ago by diego@…

  • Resolution set to worksforme
  • Status changed from new to closed

This is an old bug and the problem should go away with -fixed-vo, resolving as
WORKSFORME.

Note: See TracTickets for help on using tickets.