Opened 15 years ago

Last modified 9 years ago

#95 reopened defect

fullscreen disables stay-on-top

Reported by: tomasgroth@… Owned by: reimar
Priority: normal Component: vo
Version: HEAD Severity: minor
Keywords: Cc: diego@…, reimar, beastd
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When using the latest CVS with the follwing command:
mplayer <videofile> -ontop -fs
and the press "f" to disable fullscreen, the ontop feature is disabled as well,
which it shouldn't. I more or less tracked the problem down to x11_common.c
version 1.173-1.174, and made a little patch which makes it work, but since i'm
not familiar with the rest of the code i don't know how it will affect other setups.

patch:
Index: libvo/x11_common.c
===================================================================
RCS file: /cvsroot/mplayer/main/libvo/x11_common.c,v
retrieving revision 1.176
diff -u -r1.176 x11_common.c
--- libvo/x11_common.c 8 Aug 2004 23:22:04 -0000 1.176
+++ libvo/x11_common.c 26 Sep 2004 18:16:21 -0000
@@ -1462,11 +1462,12 @@

vo_x11_sizehint(x, y, w, h, 0);
vo_x11_setlayer(mDisplay, vo_window, vo_fs);


  • if ((!(vo_fs)) & vo_ontop)
  • vo_x11_setlayer(mDisplay, vo_window, vo_ontop);


XMoveResizeWindow(mDisplay, vo_window, x, y, w, h);

}

+ if ((!(vo_fs)) & vo_ontop)
+ vo_x11_setlayer(mDisplay, vo_window, vo_ontop);
+

#ifdef HAVE_XINERAMA

vo_x11_xinerama_move(mDisplay, vo_window);

#endif

Attachments (1)

xfce_ontop_fix.diff (535 bytes) - added by reimar 13 years ago.
hack that seems to fix the problem

Download all attachments as: .zip

Change History (11)

comment:1 Changed 15 years ago by diego@…

  • Cc diego@… added

comment:2 Changed 15 years ago by diego@…

  • Resolution set to fixed
  • Status changed from new to closed

Patch committed by Alexander Strasser, marking FIXED.

comment:3 Changed 15 years ago by tomasgroth@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

Since this bug still apears with lastest CVS (02022005) and XFCE 4.2 i'm
reopening it.
I guess the problems lies in the way -fs and -ontop are activated when use from
the commandline, since the problem only exist when mplayer is used like this:
mplayer <videofile> -ontop -fs
and the fullscreen is deactivated during playback.

When mplayer is used like this:
mplayer <videofile> -ontop
and the fullscreen is activated and then deactivated during playback, the
problem doesn't exist.

comment:4 Changed 15 years ago by diego@…

  • Cc eclipse7@… added

I cannot reproduce this with XFce 4.1. Alexander, can you look into this?

comment:5 Changed 14 years ago by diego@…

  • Owner changed from alex@… to beastd
  • Status changed from reopened to new

I can reproduce this bug with XFce 4.2, beastd, can you look into this?

comment:6 Changed 13 years ago by reimar

  • Resolution set to remind
  • Status changed from new to closed

Grr... I'm severely missing a retest state. Latest reply is almost one year
old. Please reopen if it doesn't work again in latest XFce, esp. if you have
any indication it is not a XFce bug/feature.

comment:7 Changed 13 years ago by tomasgroth@…

  • Resolution remind deleted
  • Status changed from closed to reopened

The bug still exists with xfce4 4.2.3, as described in comment #2.

Changed 13 years ago by reimar

hack that seems to fix the problem

comment:8 Changed 13 years ago by reimar

This patch seems to fix it, but I don't intend to apply unless someone finds
out _why_ it helps. My best guess so far is XFce bug, but my knowledge of this
stuff is very limited.

comment:9 Changed 13 years ago by reimar

  • Cc Reimar.Doeffinger@… added

comment:10 Changed 9 years ago by compn

  • Owner changed from beastd to reimar
Note: See TracTickets for help on using tickets.