Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#107 closed defect (duplicate)

make fails in ao_alsa.c compilation

Reported by: sebastian.manzano@… Owned by: alex@…
Priority: normal Component: ao
Version: 1.0pre5 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

cc -c -I../libvo -I../../libvo -I/usr/X11/include -O4 -march=athlon-xp
-mcpu=athlon-xp -pipe -ffast-math -fomit-frame-pointer -D_REENTRANT
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -I. -I..

-I/usr/include/SDL -D_REENTRANT -I/usr/X11/include -I/usr/include/gtk-1.2

-I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -o
ao_alsa.o ao_alsa.c
ao_alsa.c: In function `init':
ao_alsa.c:595: warning: passing arg 3 of `snd_pcm_hw_params_set_rate_near' makes
integer from pointer without a cast
after configuring, make stops with the following error:

ao_alsa.c:633: warning: passing arg 3 of
`snd_pcm_hw_params_set_period_size_near' makes integer from pointer without a cast
ao_alsa.c:642: warning: passing arg 3 of `snd_pcm_hw_params_set_periods_near'
makes integer from pointer without a cast
ao_alsa.c:662: too many arguments to function `snd_pcm_hw_params_get_buffer_size'
make[1]: * [ao_alsa.o] Error 1
make[1]: Leaving directory `/usr/local/src/MPlayer-1.0pre5/libao2'
make:
* [libao2/libao2.a] Error 2
#

Change History (1)

comment:1 Changed 15 years ago by reimar

  • Resolution set to duplicate
  • Status changed from new to closed

It seems you are using alsa libs older than 0.9.0rc4. Those currently aren't
supported and it is unsure if they ever will. So if you can, upgrade your alsa libs.
Also, this was already reported as bug #58.

* This bug has been marked as a duplicate of 58 *

Note: See TracTickets for help on using tickets.