Opened 7 years ago

Closed 7 years ago

#2093 closed defect (fixed)

DTS audio crash

Reported by: joshf87@… Owned by: reimar
Priority: normal Component: ad
Version: HEAD Severity: critical
Keywords: Cc: cehoyos
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When playing files with DTS audio, MPlayer crashes with signal 11 init_audio_codecs. Others like AAC, AC-3 etc play fime. This may have been a result of FFmpeg e88ca80dc325a0291c64e1dd3245c4943397cfa3 but I had compiled FFmpeg by itself and doesn't crash playing it through FFmpeg. I attached a verbose log and a gdb trace but I'm not sure if that will be of any use since the 'disass' command didn't work in my gdb in mingw.

Someone also suggested:
[21:51] <uau> wm4: the crash is a libav bug introduced when dts decoder was converted to output planar audio
[21:52] <uau> triggers when the downsampling case is used due to request_channels
[21:52] <uau> it allocates memory for only 2 channels but writes to NULL pointer for other channels before downsampling
[21:53] <uau> fix hasn't been applied to git yet

I uploaded a 5MB sample to the mplayer ftp by the name of 'H264_DTS_sig11_initaudiocodecs.mkv'.

MPlayer r35243 / FFmpeg 5a75924dfd432c0ada79a9f489889dc92d53b481 / MinGW GCC 4.6.2 on Windows

Attachments (1)

H264_DTS_sig11_initaudiocodecs.txt (12.9 KB) - added by joshf87@… 7 years ago.
mplayer log /gdb

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by joshf87@…

mplayer log /gdb

comment:1 Changed 7 years ago by cehoyos

  • Cc cehoyos@… added

This is FFmpeg ticket #1827, work-around is to add -channels 8 / -channels 6 to the command line.

comment:2 Changed 7 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed

This may be fixed, if not, it is a duplicate of bug 2098 (that also links to a sample).

Note: See TracTickets for help on using tickets.