Opened 15 years ago

Closed 13 years ago

Last modified 13 years ago

#229 closed defect (fixed)

flac decoder failed with ogg file

Reported by: castet.matthieu@… Owned by: reimar
Priority: normal Component: ad
Version: HEAD Severity: normal
Keywords: Cc: calestyo@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hi,

I just generated a flac ogg file with falc --ogg /tmp/toto.wav and when i try to
play it with mplayer it fail [1].
The file is readable with flac -d -c /tmp/t.ogg | aplay...

Matthieu.

PS : I could upload the file if needed

[1]
MPlayer dev-CVS-050204-18:50-3.3.5 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Athlon 4 /Athlon MP/XP Palomino (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Failed to open /dev/rtc: Permission denied (it should be readable by the user.)
Playing /tmp/t.ogg.
Ogg stream 0 is of an unknown type
Ogg stream 0 is of an unknown type
Audio file detected.
==========================================================================
Trying to force audio codec driver family ffmpeg...
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
size 0 34
[flac @ 0x8637800]STREAM HEADER
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 34
[flac @ 0x8637800] Blocksize: 4608 .. 4608 (0)
[flac @ 0x8637800] Framesize: 0 .. 18432
[flac @ 0x8637800] Samplerate: 44100
[flac @ 0x8637800] Channels: 2
[flac @ 0x8637800] Bits: 16
[flac @ 0x8637800] metadata block: flag = 0, type = 18, size = 4608
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 0
[flac @ 0x8637800] metadata block: flag = 0, type = 0, size = 5203815
mplayer: flac.c:209: allocate_buffers: Assertion `s->max_blocksize' failed.

MPlayer interrupted by signal 6 in module: init_audio_codec

  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

Attachments (1)

new_flac_in_ogg.diff (1.7 KB) - added by reimar 13 years ago.
support new flac-in-ogg in native demuxer

Download all attachments as: .zip

Change History (9)

comment:1 Changed 13 years ago by diego@…

  • Owner changed from alex@… to r_togni@…

comment:2 Changed 13 years ago by diego@…

Could you please provide a sample file?

comment:3 Changed 13 years ago by castet.matthieu@…

Any flac in ogg file should show the problem.

For example :
flac --ogg -o /tmp/test_flac.ogg /tmp/test.wav

http://castet.matthieu.free.fr/broken/test_flac.ogg

With cvs version of mplayer I have :

$mplayer /tmp/test_flac.ogg MPlayer dev-CVS-060430-22:50-4.0.4
(C) 2000-2006 MPlayer Team
CPU: Advanced Micro Devices Duron/Athlon? 4/MP/XP Palomino (Family: 6, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Failed to open /dev/rtc: Permission denied (it should be readable by the user.)

Playing /tmp/test_flac.ogg.
Ogg stream 0 is of an unknown type
Ogg stream 0 is of an unknown type
Audio file file format detected.
==========================================================================
Trying to force audio codec driver family ffmpeg...
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders

MPlayer interrupted by signal 11 in module: init_audio_codec

  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

comment:4 Changed 13 years ago by reimar

Works with -demuxer lavf. Will attach a patch that fixes the issue completely.

Changed 13 years ago by reimar

support new flac-in-ogg in native demuxer

comment:5 Changed 13 years ago by reimar

  • Owner changed from r_togni@… to Reimar.Doeffinger@…
  • Status changed from new to assigned

comment:6 Changed 13 years ago by reimar

  • Resolution set to fixed
  • Status changed from assigned to closed

Patch applied in SVN r20505.

comment:7 Changed 13 years ago by reimar

  • Cc calestyo@… added

comment:8 Changed 13 years ago by reimar

* Bug 622 has been marked as a duplicate of this bug. *

Note: See TracTickets for help on using tickets.