Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#376 closed defect (worksforme)

MP4 file with FAAD audio is not able to decode audio

Reported by: jg@… Owned by: alex@…
Priority: normal Component: ao
Version: 1.0pre7 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I downloaded the first set of shows from the torrent here:
http://www.go-opensource.org/go_open/news/download_go_open/

There is a problem with the audio part of the file at present. I wonder if
someone could confirm if it is also a problem for them, I am using pre7

Linux now2g 2.6.8-2-k7 #1 Thu May 19 18:03:29 JST 2005 i686 GNU/Linux

libc-2.3.2.so

$ gcc -v
Reading specs from /usr/lib/gcc-lib/i486-linux/3.3.5/specs
Configured with: ../src/configure -v
--enable-languages=c,c++,java,f77,pascal,objc,ada,treelang --prefix=/usr
--mandir=/usr/share/man --infodir=/usr/share/info
--with-gxx-include-dir=/usr/include/c++/3.3 --enable-shared
--enable-cxa_atexit --with-system-zlib --enable-nls --without-included-gettext
--enable-clocale=gnu --enable-debug --enable-java-gc=boehm
--enable-java-awt=xlib --enable-objc-gc i486-linux
Thread model: posix
gcc version 3.3.5 (Debian 1:3.3.5-13)

$ ld -v
GNU ld version 2.15

GNU assembler 2.15

When I do -ao none the video part plays ok. The file plays ok in QuickTime? I
am informed. vlc gets about half way through and then it stops playing the audio
as welll. Xine plays, but no audio.

$ mplayer -v go-open-episode-02.mp4
MPlayer 1.0pre7-3.3.5 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP/XP-M Barton (Family: 6, Stepping: 0)
Detected cache-line size is 64 bytes
MMX2 supported but disabled
3DNow supported but disabled
3DNowExt supported but disabled
CPUflags: MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX SSE

CommandLine?: '-v' 'go-open-episode-02.mp4'
init_freetype
get_path('font/font.desc') -> '/home/now3d/.mplayer/font/font.desc'
font: can't open file: /home/now3d/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using MMX Optimized OnScreenDisplay?
Using Linux hardware RTC timing (1024Hz).
get_path('input.conf') -> '/home/now3d/.mplayer/input.conf'
Can't open input config file /home/now3d/.mplayer/input.conf: No such file or
directory
Parsing input config file /etc/mplayer/input.conf
Input config file /etc/mplayer/input.conf parsed: 59 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
get_path('go-open-episode-02.mp4.conf') ->
'/home/now3d/.mplayer/go-open-episode-02.mp4.conf'
Playing go-open-episode-02.mp4.
[file] File size is 109619005 bytes
STREAM: [file] go-open-episode-02.mp4
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
CACHE_PRE_INIT: 0 [0] 0 pre:0 eof:253952
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for Nullsoft Streaming Video
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename go-open-episode-02.mp4 ext: .mp4
Trying demuxer 7 based on filename extension
Checking for MOV
ISO: File Type Major Brand: ISO Base Media
ISO: File Type Minor Version: 512
ISO: File Type Compatible Brand #0: mp41
MOV: Movie DATA found!
MOV: Movie header found!
QuickTime?/MOV file format detected.
MOV: Movie header (100 bytes): tscale=1000 dur=1436293


MOV: Track #0:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=1 dur=1436040 lay=0 vol=0
MOV: Media stream!
MOV: Media header!
MOV: Handler header: /vide () VideoHandler?
MOV: unknown handler class: 0x0 ()
MOV: Media info!
MOV: Video header!
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4v (164 bytes)
MOV: Sample duration table! (1 blocks)
MOV: Syncing samples (keyframes) table! (302 entries) (ver:0,flags:0)
MOV: Sample->Chunk mapping table! (1 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=35901 ss=0) (ver:0,flags:0)
MOV: Chunk offset table! (35901 chunks)
MOV track #0: 35901 chunks, 35901 samples
pts=35901 scale=25 time=1436.040
==> Found video stream: 0
MOV: Found MPEG4 movie Elementary Stream Descriptor atom (94)!
ESDS MPEG4 version: 0 flags: 0x000000
ESDS MPEG4 ES Descriptor (80Bytes):

-> ESId: 1
-> streamPriority: 0

ESDS MPEG4 Decoder Config Descriptor (72Bytes):

-> objectTypeId: 32
-> streamType: 0x11
-> bufferSizeDB: 0x000DD2
-> maxBitrate: 190.744kbit/s
-> avgBitrate: 97.899kbit/s

ESDS MPEG4 Decoder Specific Descriptor (57Bytes)
ESDS MPEG4 Sync Layer Config Descriptor (1Bytes)

-> predefined: 2

Image size: 480 x 352 (24 bpp)
Display size: 469 x 352
Fourcc: mp4v Codec:


MOV: Track #1:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=2 dur=1436293 lay=0 vol=256
MOV: Media stream!
MOV: Media header!
MOV: Handler header: /soun () SoundHandler?
MOV: unknown handler class: 0x0 ()
MOV: Media info!
MOV: Sound header!
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4a (59 bytes)
MOV: Sample duration table! (1 blocks)
MOV: Sample->Chunk mapping table! (1 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=30928 ss=0) (ver:0,flags:0)
MOV: Chunk offset table! (30928 chunks)
MOV track #1: 30928 chunks, 30928 samples
pts=31670272 scale=22050 time=1436.294
==> Found audio stream: 1
Audio bits: 16 chans: 2 rate: 22050
MOV: Found MPEG4 audio Elementary Stream Descriptor atom (39)!
ESDS MPEG4 version: 0 flags: 0x000000
ESDS MPEG4 ES Descriptor (25Bytes):

-> ESId: 1
-> streamPriority: 0

ESDS MPEG4 Decoder Config Descriptor (17Bytes):

-> objectTypeId: 64
-> streamType: 0x15
-> bufferSizeDB: 0x000DD2
-> maxBitrate: 190.744kbit/s
-> avgBitrate: 97.899kbit/s

ESDS MPEG4 Decoder Specific Descriptor (2Bytes)
ESDS MPEG4 Sync Layer Config Descriptor (1Bytes)

-> predefined: 2

Fourcc: mp4a


Quicktime Clip Info:

Requirements: QuickTime? 6.0 or greater

MOV: longest streams: A: #1 (30928 samples) V: #0 (35901 samples)
VIDEO: [mp4v] 480x352 24bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:7 fourcc:0x7634706D size:480x352 fps:25.00 ftime:=0.0400
get_path('sub/') -> '/home/now3d/.mplayer/sub/'
get_path('default.sub') -> '/home/now3d/.mplayer/default.sub'
==========================================================================
Trying to force audio codec driver family libmad...
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
dec_audio: Allocating 4608 bytes for input buffer.
dec_audio: Allocating 49152 + 65536 = 114688 bytes for output buffer.
FAAD: Decoder init done (0Bytes)!
FAAD: Negotiated samplerate: 44100Hz channels: 2
FAAD: got 97kbit/s bitrate from MP4 header!
AUDIO: 44100 Hz, 2 ch, s16le, 97.9 kbit/6.94% (ratio: 12237->176400)
Selected audio codec: [faad] afm:faad (FAAD AAC (MPEG2/MPEG4 Audio) decoder)
==========================================================================
X11 opening display: :0
vo: X11 color mask: FFFFFF (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0" => local display)
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Detected wm supports ABOVE state.
[x11] Detected wm supports BELOW state.
[x11] Detected wm supports STAYS_ON_TOP state.
[x11] Current fstype setting honours FULLSCREEN STAYS_ON_TOP ABOVE BELOW X atoms
[xv common] Drawing no colorkey.
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
INFO: libavcodec init OK!
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
==========================================================================
Checking audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 44100Hz/2ch/s16le
AF_pre: 44100Hz/2ch/s16le
alsa-init: requested format: 44100 Hz, 2 channels, 9
alsa-init: compiled for ALSA-1.0.8
alsa-init: setup for 1/2 channel(s)
alsa-init: 1 soundcard found, using: default
alsa-init: pcm opend in block-mode
alsa-init: chunksize set to 1024
alsa-init: fragcount=14
alsa-init: got buffersize=57364
alsa: 44100 Hz/2 channels/4 bpf/57364 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 44100Hz 2ch s16le (2 bps)
AO: Description: ALSA-0.9.x-1.x audio output
AO: Author: Alex Beregszaszi, Zsolt Barat <joy@…>
AO: Comment: under developement
Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
Starting playback...
alsa-space: free space = 57364, prepared --
FAAD: Failed to decode frame: Unexpected channel configuration change
FAAD: Failed to decode frame: Unexpected channel configuration change
FAAD: Failed to decode frame: Unexpected channel configuration change
<snip>

Change History (4)

comment:1 Changed 15 years ago by jg@…

With -ao null I do get the same FAAD messages constantly in the terminal window.
Sorry my original test was incorrectly -ao none

FAAD: Failed to decode frame: Unexpected channel configuration change

comment:2 Changed 15 years ago by reimar

I could play them without any problem some time ago. Please try with latest CVS.

comment:3 Changed 15 years ago by jg@…

Hi, Was your CVS build after 1.0pre7-3.3 ?

Others confirmed the problem was present in CVS when I submitted the bug to on
18 Sept. Was your CVS after that?

Kind regards
JG

comment:4 Changed 15 years ago by jg@…

  • Resolution set to worksforme
  • Status changed from new to closed

Hi, I tried the latest snapshot, it works now.
I've set it WFM.
JG

Note: See TracTickets for help on using tickets.