Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#419 closed defect (worksforme)

software scaler -> signal 11 in module: decode_video

Reported by: alpha0x89@… Owned by: r_togni@…
Priority: normal Component: vd
Version: HEAD Severity: normal
Keywords: Cc: dominik@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The following command will make MPlayer (latest CVS) crash:

mplayer -vo x11 -sws 2 -zoom -xy 2 moviefile.avi

The only software scaler algorithm that wont't make MPlayer crash is "fast
bilinear" (-sws 0), though '-sws 0' used without '-x', '-y' or '-xy' causes a
crash as well:

mplayer -vo x11 -sws 0 -zoom moviefile.avi


System details:

SuSE Linux 9.3
glibc 2.3.4
Kernel 2.6.11.4-21.9-default
gcc version 3.3.5 20050117 (prerelease)
GNU ld version 2.15.94.0.2.2 20041220
GNU assembler 2.15.94.0.2.2 20041220

Truncated output of 'mplayer -v -v -vo x11 -sws 2 -zoom -xy 2':

MPlayer dev-CVS-051216-18:13-3.3.5 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Athlon Thunderbird (Family: 6, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx

[...]

==========================================================================
X11 opening display: :0
vo: X11 color mask: FFFF (R:F800 G:7E0 B:1F)
vo: X11 running at 800x600 with depth 16 and 16 bpp (":0" => local display)
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Detected wm supports ABOVE state.
[x11] Detected wm supports BELOW state.
[x11] Detected wm supports STAYS_ON_TOP state.
[x11] Current fstype setting honours FULLSCREEN STAYS_ON_TOP ABOVE BELOW X
atoms
==========================================================================

[...]

avg. framerate: 15 fps
vd_ffmpeg data: 81818c0d, 175e78f1, 5e78e185, 78e18517
[ffmpeg] aspect_ratio: 0.000000
VDec: vo config request - 320 x 240 (preferred colorspace: Planar YV12)
Trying filter chain: vo
vo_x11: query_format was called: 32315659 (Planar YV12)
vo_debug: query(Planar YV12) returned 0x445 (i=0)
vo_x11: query_format was called: 30323449 (Planar I420)
vo_debug: query(Planar I420) returned 0x445 (i=1)
vo_x11: query_format was called: 56555949 (Planar IYUV)
vo_debug: query(Planar IYUV) returned 0x445 (i=2)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO Config (320x240->640x480,flags=4,'MPlayer',0x32315659)
VO: [x11] 320x240 => 640x480 Planar YV12 [zoom]
VO: Description: X11 ( XImage/Shm )
VO: Author: Aaron Holtzman <aholtzma@…>
vo_x11: query_format was called: 32315659 (Planar YV12)
Sharing memory.
1.000 |
1.000 |
SwScaler?: using unscaled Planar YV12 -> BGR 16-bit special converter
using IP
* [vo] Allocating (slices) mp_image_t, 320x240x12bpp YUV planar, 115200
bytes
(imgfmt: 32315659, planes: 8a48180,8a5f880,8a5ad80 strides: 320,160,160,
chroma: 160x120, shift: h:1,v:1)
1.000 |
1.000 |
SwScaler?: reducing / aligning filtersize 5 -> 4
SwScaler?: reducing / aligning filtersize 5 -> 4
SwScaler?: reducing / aligning filtersize 5 -> 4
SwScaler?: reducing / aligning filtersize 5 -> 4

SwScaler?: BICUBIC scaler, from Planar YV12 to dithered BGR 16-bit using MMX2
SwScaler?: using 4-tap MMX scaler for horizontal luminance scaling
SwScaler?: using 4-tap MMX scaler for horizontal chrominance scaling
SwScaler?: using n-tap MMX scaler for vertical scaling (BGR)
SwScaler?: using MMX YV12->BGR16 Converter
SwScaler?: 320x240 -> 640x480
SwScaler:Lum srcW=320 srcH=240 dstW=640 dstH=480 xInc=32768 yInc=32768
SwScaler:Chr srcW=160 srcH=120 dstW=320 dstH=480 xInc=32768 yInc=16384


MPlayer interrupted by signal 11 in module: decode_video

  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible

bug.

Change History (3)

comment:1 Changed 13 years ago by dominik@…

  • Cc dominik@… added

Works for me with current (20060228) CVS, please retry with current and if it
persists, provide a gdb backtrace, otherwise we can't fix it.

comment:2 Changed 13 years ago by diego@…

  • Component changed from vo to vd
  • Owner changed from alex@… to r_togni@…

comment:3 Changed 13 years ago by dominik@…

  • Resolution set to worksforme
  • Status changed from new to closed

No reply for over two months, closing as WORKSFORME. If it still occurs with
current CVS, please reopen.

Note: See TracTickets for help on using tickets.