Opened 13 years ago

Closed 11 years ago

Last modified 11 years ago

#665 closed defect (wontfix)

add ability to swtich audio streams in OGM using # key

Reported by: compn Owned by: diogomfranco@…
Priority: normal Component: demuxer
Version: HEAD Severity: minor
Keywords: Cc: diogomfranco@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

switching audio streams in ogm does not work with mplayer demuxer

workaround: use -demuxer lavf

Change History (9)

comment:1 Changed 11 years ago by diogomfranco@…

  • Cc diogomfranco@… added
  • Status changed from new to assigned

I'm having the same problem.

I saw on the source code that the code to change audio on OGG/OGM is simply not implemented. I'll give a shot at implementing it.

comment:2 Changed 11 years ago by diogomfranco@…

  • Component changed from core to demuxer
  • Owner changed from Reimar.Doeffinger@… to diogomfranco@…
  • Status changed from assigned to new

comment:3 Changed 11 years ago by diogomfranco@…

  • Status changed from new to assigned

comment:4 Changed 11 years ago by diogomfranco@…

  • Severity changed from enhancement to minor

comment:5 Changed 11 years ago by reimar

Better implement the subtitle support (and fix whatever other shortcomings/bugs it may have) for the lavf demuxer and make that one the default.

comment:6 Changed 11 years ago by diogomfranco@…

  • Resolution set to wontfix
  • Status changed from assigned to closed

It appears that libavformat doesn't implement subtitle reading on OGG, so the lavf demuxer can't do the subtitle magic. I'll file a bug on ffmpeg (if it isn't filed already).

Since it is better to avoid code duplication, I'll set this to WONTFIX and see what happens on lavf. After it is fixed, we set it as the default for ogg.

comment:7 Changed 11 years ago by reimar

Well, it is not code duplication as such, but it will be wasted time since we will switch all demuxers to lavf code in the long run.
You do not need to report the missing text subtitle support, I sent a patch for that.
But report if you have problems with text subtitles with that patch or if you have some other subtitles (I heard rumors about vobsub in ogg, but I have no samples).
There is at least one remaining issue with the lavf ogg demuxer, it does not display a language name for the subtitles.

comment:8 Changed 11 years ago by diogomfranco@…

Well, when you wrote that I had already sent a report to the libav* maling list. Oh well, if it doesn't do any good at least it won't do any evil.

I will set lavf as the default demuxer on my working copy and see what's up on lavf. I'm new to DSP and media, so I'm a bit lost on libavformat code, but I'll try to figure it out.

comment:9 Changed 11 years ago by reimar

libavformat code should be much simpler to understand that our demuxer.
Anyway, subtitle support is in now, support for displaying track language is pending but may not be accepted since this feature was never properly specified.
If you have problems with ogg lavf demuxer, report them.

Note: See TracTickets for help on using tickets.