Opened 13 years ago

Last modified 9 years ago

#667 closed defect (worksforme)

MPlayer interrupted by signal 11 in module: filter_video

Reported by: felix_adrianto@… Owned by: nicolas.plourde@…
Priority: normal Component: MPlayer OS X
Version: HEAD Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I tried to compile MPlayer svn 21451 with XCode 2.4.1, everything went fine
until I played all my video files. MPlayer started to open the window but it
crashed right away. The file can be played without the video (-vo null so audio
only). None of my movies can be played in Osx86. The same source code was
compiled under Linux and everything was fine.

This was happening in the last 2 weeks.

Does anyone have the same problem with me? Is it a bug in MPlayer OS X?

VIDEO: [XVID] 608x336 24bpp 23.976 fps 1022.0 kbps (124.8 kbyte/s)
Clip info:

Software: cant touch this

==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [macosx] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 608 x 336 (preferred colorspace: Planar YV12)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.81:1 - prescaling to correct movie aspect.
SwScaler?: reducing / aligning filtersize 1 -> 4
SwScaler?: reducing / aligning filtersize 1 -> 4
SwScaler?: reducing / aligning filtersize 1 -> 1
SwScaler?: reducing / aligning filtersize 5 -> 4
SwScaler?: BICUBIC scaler, from yuv420p to yuyv422 using MMX2
SwScaler?: using 4-tap MMX scaler for horizontal luminance scaling
SwScaler?: using 4-tap MMX scaler for horizontal chrominance scaling
SwScaler?: using n-tap MMX scaler for vertical scaling (BGR)
SwScaler?: 608x336 -> 608x336
VO: [macosx] 608x336 => 608x336 Packed YUY2
A: 0.4 V: 0.0 A-V: 0.416 ct: 0.000 1/ 1 ??% ??% ??,?% 0 0

MPlayer interrupted by signal 11 in module: filter_video

  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

Change History (11)

comment:1 Changed 13 years ago by compn

can you try with -vo quartz ?

comment:2 Changed 13 years ago by felix_adrianto@…

(In reply to comment #1)

can you try with -vo quartz ?

I never can play any files with quartz. I just crashed right away MPlayer would
not even try to open any window.

I noticed that in the last couple of weeks, I got the following errors when the
compiler try to link everything together

/usr/bin/ld: warning multiple definitions of symbol _LoadResource
loader/libloader.a(resource.o) definition of _LoadResource in section
(TEXT,text)
/System/Library/Frameworks/CoreServices?.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore(ProjectBuilderMasterObjectFile?.o)
definition of _LoadResource
/usr/bin/ld: Undefined symbols:
Unwind_Resume
collect2: ld returned 1 exit status
make: * [mplayer] Error 1

There is a workaround by passing -fexceptions or using g++ then MPlayer will be
able to compile successfuly. I am not sure if this is something to do with my
problem or not.

comment:3 Changed 13 years ago by nicolas.plourde@…

vo quartz is broken on x86 osx. vo macosx should work perfectly, can you give me more information on
the model of mac you are using and the osx version running?

comment:4 Changed 13 years ago by felix_adrianto@…

(In reply to comment #3)

vo quartz is broken on x86 osx. vo macosx should work perfectly, can you give

me more information on

the model of mac you are using and the osx version running?

I am using Osx86 10.4.8 with Mach 8.4.1. I installed XCode 2.4.1 gcc 4.0.1.
My hardware spec is Intel P4 Prescott SSE3, Radeon 9700 Pro, 1Gb DDR Ram.

comment:5 Changed 13 years ago by nicolas.plourde@…

Since I cant reproduce the problem on my iMac I will assume this is related to
the hacked osx kernel + non compatible video driver you are using. Try your
binary on a real intel mac to see if it work.

comment:6 Changed 13 years ago by felix_adrianto@…

(In reply to comment #5)

Since I cant reproduce the problem on my iMac I will assume this is related to
the hacked osx kernel + non compatible video driver you are using. Try your
binary on a real intel mac to see if it work.

I don't have an access to the real iMac. This is just happening recently (2
weeks), I was able to compile and play all my movies from SVN 1 month ago. I
installed the binary version from unofficial website from the net, it works
perfectly without any problem.

I wonder if there are big changes in the last few weeks?

comment:7 Changed 13 years ago by felix_adrianto@…

  • Resolution set to invalid
  • Status changed from new to closed

I know what the problem is, I just recently uninstalled darwinports then
compiled all the library from source code. One of the library is causing a
problem, I don't know which one yet, I disable all the library in
/usr/local/lib, mplayer can be compiled and played my files without any problem.

We can closed this bug.

comment:8 Changed 13 years ago by felix_adrianto@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

I found the culprit, it is the freetype. Darwinports installed freetype 2.1.10
to my system, recently I deleted darwinports and compiled freetype 2.2.1.
MPlayer can be compiled successfully but it won't play any files because of the
runtime error. I am assuming the same error would be generated in your real iMac
if you installed freetype 2.2.1. Correct me if I am wrong.

comment:9 Changed 13 years ago by felix_adrianto@…

  • Status changed from reopened to new

Did someone has the same problem with me by installing freetype 2.2.1 in the
real iMac?

comment:10 Changed 13 years ago by nicolas.plourde@…

freetype 2.2.1 work fine here.

comment:11 Changed 9 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed, patriotact@gmail.com

closing bug

Note: See TracTickets for help on using tickets.