Opened 10 years ago

Closed 3 years ago

#958 closed defect (worksforme)

Problem with default font in gmplayer

Reported by: amir.livne.baron@… Owned by: ib
Priority: normal Component: GUI
Version: 1.0rc2 Severity: normal
Keywords: Cc: ib
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: yes

Description

The default font does not contain Hebrew characters, so when using Hebrew subtitle files, the user cannot see the subtitles.

One solution is to change the default font.

Another is to include a line like "font=C:\Windows\Fonts\arial.ttf" in the default config file (or some other widespread Hebrew font). This will fall back to the default font if arial.ttf does not exist.

Change History (4)

comment:1 Changed 10 years ago by mplayer@…

(In reply to comment #0)

The default font does not contain Hebrew characters, so when using Hebrew
subtitle files, the user cannot see the subtitles.

One solution is to change the default font.

Another is to include a line like "font=C:\Windows\Fonts\arial.ttf" in the
default config file (or some other widespread Hebrew font). This will fall back
to the default font if arial.ttf does not exist.

I don't think this can be flagged as bug, does arial contains chinese or japanese fonts? I doubt
btw I've received some reports about problems with hebrew fonts
by using freedibi and/or some combination
iirc the problems were related to r-to-l alignment with accented letters (possible) unfortunately I'm not able to understand hebrew

something like:

-flip-hebrew -fribidi-charset UTF-8 -subfont-encoding unicode -utf8

in matroska container

comment:2 Changed 10 years ago by amir.livne.baron@…

I think this is a bug, because fonts should work without manual configuration.

On Linux, there is a flag -fontconfig that allows mplayer to find a correct font without manual settings (although it isn't set by default).

On MinGW, mplayer is not compiled with fontconfig, and I didn't see any other font fallback mechanism, so the font must be specified manually. In this situation, not supplying a pan-unicode font is a bug in my view. If arial is not such a font, then another one should be used.

The recent version of mplayer handles fribidi well, I didn't see any problem with it. Accented characters usually appear in Hebrew files because the files are encoded in 8-bit encodings and not in utf-8, and the locale is not configured correctly.

comment:3 Changed 5 years ago by ib

  • Cc ib@… added
  • Owner changed from reimar to ib

comment:4 Changed 3 years ago by ib

  • Analyzed by developer set
  • Reproduced by developer unset
  • Resolution set to worksforme
  • Status changed from new to closed

Fonts do work without manual configuration by now.

The font defaults are:

  • for Fontconfig: sans-serif
  • or (fallback) for FreeType: ~/.mplayer/subfont.ttf (or in system-wide MPlayer data directory)
  • or (fallback) else: ~/.mplayer/font/font.desc (or in system-wide MPlayer data directory)

Needless to say, the default has to contain the required encoding (or the font chosen by the user in the preferences has to).

Note: See TracTickets for help on using tickets.