Opened 12 years ago

Closed 10 years ago

#990 closed defect (duplicate)

Need to report file errors with more details

Reported by: yuri@… Owned by: r_togni@…
Priority: normal Component: streaming
Version: unspecified Severity: normal
Keywords: Cc: pacho@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I tried to play DVD saved as a directory.
Some files had no permissionto open them.

mplayer gave me error log (see below) saying nothing about the real problem.

MPlayer should say: Can't open DVD_DIRECTORY/VIDEO_TS/VIDEO_TS.IFO: Permission denied.
Or something like this.
Need to give user a clue what's wrong.

Yuri


[yuri@myhost /yuri-huge/movies]$ mplayer dvd:// -sid 0 -vo xv -alang english -dvd-device DVD_DIRECTORY/
MPlayer 1.0rc1-4.2.1 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) 64 Processor 3200+ (Family: 15, Model: 4, Stepping: 8)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.

Playing dvd://.
libdvdread: Couldn't find device name.
libdvdread: Can't open file VIDEO_TS.IFO.
Can't open VMG info!
[file] No filename
Failed to open dvd://.

Change History (2)

comment:1 Changed 11 years ago by pacho@…

  • Cc pacho@… added
  • op_sys changed from FreeBSD to All

comment:2 Changed 10 years ago by compn

  • Resolution set to duplicate
  • Status changed from new to closed

there is a patch that maybe applied soon
see bug 1102

* This bug has been marked as a duplicate of bug 1102 *

Note: See TracTickets for help on using tickets.